I have the same problems as Sven, so sorry for hijacking this thread.

Am Samstag 09 April 2011 schrieb Radek Polak:
> Sven Hartrumpf wrote:
> > When I started QX from the GUI I had to install an X server.
> > Which one is recommended? (Xorg or Xglamo?)
> I would go for Xglamo - it's very small (~1MB) and well tested. I have
> tested it on fresh v35 install and i worked just fine.

Wich packages do I have to install for Xglamo?

A "apt-cache search glamo" gives only the result "xserver-xorg-video-glamo - 
X.Org X server -- SMedia Glamo display driver"

I have installed this package, but the X server is not starting.

> > I tried both, but with no success (I saw Raptor install packages,
> > but no error message; it could be that the root fs is full now).
> > 
> > So, I tried
> > 
> > apt-get install xserver-xorg
> > 
> > which worked, but starting xterm (or navit) from QX leads to:
> > 
> > "Unable to connect to X server"
> If you try running"X" from command line does it work? Maybe uninstall the
> xserver-xorg (or remove /usr/bin/X) and QX should use Xglamo automatically.

A start of "X" gives the error

"Failed to load module "fbdev"" 

So I installed the package "xserver-xorg-video-fbdev"

Now the error was:

"(EE) AIGLX error: dlopen of /usr/lib/dri/swrast_dri.so failed 
(/usr/lib/dri/swrast_dri.so: cannot open shared object file: No such file or 
(EE) GLX: could not load software renderer"

After the installing "libxcb-glx0 libgl1-mesa-swx11 libgl1-mesa-dri" I get no 
error messages, only this output

"root@neo:~# X&

X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.31-rc9 armv5tel Debian
Current Operating System: Linux neo 2.6.34-qtmoko #1 Tue Mar 29 19:36:17 UTC 
2011 armv4tl
Kernel command line: loglevel=4 console=tty0 console=ttySAC2,115200 
init=/sbin/init ro  mtdparts=physmap-flash:-(nor);neo1973-
ext2),0x0f6a0000(rootfs)  g_ether.dev_addr=00:1F:11:01:55:3F 
g_ether.host_addr=00:1F:11:01:55:40  root=/dev/mmcblk0p1 rootdelay=1 
console=tty0 loglevel=3 rootwait
Build Date: 19 February 2011  03:00:40PM
xorg-server 2:1.7.7-13 (Cyril Brulebois <k...@debian.org>) 
Current version of pixman: 0.16.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sun Apr 10 11:03:15 2011
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Primary device is not PCI
SELinux: Disabled on system, not enabling in X server"

The screen becomes black and after clicking on the screen the graphic is 
redrawn. But a start of navit gives the old message

root@neo:~# navit
navit:main_init:Warning: LC_ALL is set, this might lead to problems (e.g. 
strange positions from GPS)
map_rect_new_textfile unable to open textfile /root/.navit/bookmark.txt

(<unknown>:1081): Gtk-WARNING **: cannot open display:"

Greetings, Carsten

Openmoko community mailing list

Reply via email to