Mandy Chung wrote:
Alan, David, Remi, Iris,

Thanks for the review and the revised webrev at:
    http://cr.openjdk.java.net/~mchung/6878481/webrev.01/

I incorporate the comments you have and minimize the number of System.nanoTime() calls and also remove the number of opened jars perf counters. Please let me know if you have further comments.
This looks much better, in particular the overhead in ClassLoader is much reduced. Also, I see you've removed the special counter for JAR files, which make sense.

Minor nit but I assume you can initialize perf as:
 private static final Perf perf =
    AccessController.doPrivileged(new Perf.GetPerfAction());

Also minor nit: in the javadoc of the PerfCounter's public methods - I assume you meant to use /** instead of /*.

Method naming is hard (and often subjective) but there are updates like this:
 PerfCounter.getParentDelegationTime.inc(t1 - t0);
which might be easier to read as:
 PerfCounter.getParentDelegationCounter().addTime(t1 - t0)

Also:
 PerfCounter.getZipFileCount().inc();
which might be cleaer as:
 PerfCounter.getZipFileCounter().increment();

Just a suggestion of course. Otherwise, looks okay to me and I'm looking forward to seeing the output once these changes are in.

-Alan.

Reply via email to