Hi, Robert. Thanks for Reviewing!
iris -----Original Message----- From: Robert Field Sent: Wednesday, July 20, 2016 6:16 PM To: Iris Clark; Kumar Srinivasan; Java Core Libs; [email protected]; [email protected] Subject: Re: RFR(s) 8161236: Runtime.Version.{compareTo, equals}IgnoreOpt should be renamed Thumbs up on JShell change. -Robert On 07/20/16 13:10, Iris Clark wrote: > Hi. > > > > Please review changes in jdk and langtools (module jdk.jshell) to address the > following bug: > > > > 8161236: Runtime.Version.{compareTo,equals}IgnoreOpt should be renamed > > https://bugs.openjdk.java.net/browse/JDK-8161236 > > > > Webrev: > > > > http://cr.openjdk.java.net/~iris/verona/8161236/webrev.0/ > > > > We update the method declarations to replace the token "Opt" with "Optional", > thus aligning the method names with the associated getter, > Runtime.Version.optional(). Specification references to those methods and > any uses of the methods were also updated. > > > > JPRT runs (testsets hotspot and pit) show no failures related to these > changes. A CCC request is in flight. > > > > Regards, > > Iris > >
