On 17/10/2016 12:17, Claes Redestad wrote:
This looks okay, I just wondering if JavaNetAccess should be renamed to
JavaNetUriAccess to avoid it being used to access other classes in
java.net. If renamed then I guess createUri could be renamed to create too.
one partial cause for startup regressions due to jigsaw is related to
URIs for the location of each module.
By providing a package-private constructor we can avoid the time to
validate the URI, which takes a little time (executes ~80K bytecodes)
pushes various methods over compilation thresholds during early startup,
which more notably interferes with perceived startup.