On Thu, 17 Dec 2020 13:32:06 GMT, Daniel Fuchs <dfu...@openjdk.org> wrote:

>> Actually, I'm not sure if `oth` is better name for variable than `other1`.
>> I would say they have the same rank :)
>
> I believe Alan is suggesting to do:
> 
>     /**
>      * Compares the equality of two <code>Signal</code> objects.
>      *
>      * @param obj the object to compare with.
>      * @return whether two <code>Signal</code> objects are equal.
>      */
>     public boolean equals(Object obj) {
>         if (this == obj) {
> 
> this leaves the variable name `other` free for later use inside the method.

> Actually, I'm not sure if `oth` is better name for variable than `other1`.
> I would say they have the same rank :)

Sorry, I should have been clearer, the comment was about equals(Object other). 
If you rename "other" then it will avoid "other1"

-------------

PR: https://git.openjdk.java.net/jdk/pull/20

Reply via email to