On Wed, 13 Dec 2023 18:38:09 GMT, Tim Prinzing <tprinz...@openjdk.org> wrote:

>> Added mirror event with static methods: jdk.internal.event.SelectionEvent 
>> that provides the duration of select calls and the count of how many keys 
>> are available.
>> 
>> Emit the event from SelectorImpl::lockAndDoSelect
>> 
>> Test at jdk.jfr.event.io.TestSelectionEvents
>
> Tim Prinzing has updated the pull request with a new target base due to a 
> merge or a rebase. The incremental webrev excludes the unrelated changes 
> brought in by the merge/rebase. The pull request contains 12 additional 
> commits since the last revision:
> 
>  - Change event generation:
>    
>    - selectNow is filtered out
>    - select that times out is always sent
>    - select without timeout uses duration test
>  - rename event to SelectorSelect, field to selectionKeyCount.
>  - Merge branch 'master' into JDK-8310994
>  - remove trailing whitespace
>  - event logic outside of the lock, selector in try block
>  - remove unused import
>  - fix TestConfigure failure
>  - add event defaults
>  - Merge branch 'master' into JDK-8310994
>  - minor test cleanup
>  - ... and 2 more: https://git.openjdk.org/jdk/compare/ddad6141...2f7dafd8

src/java.base/share/classes/jdk/internal/event/SelectorSelectEvent.java line 41:

> 39: public class SelectorSelectEvent extends Event {
> 40: 
> 41:     public int selectionKeyCount;

I still believe we should record the timeout parameter in the event.

src/jdk.jfr/share/classes/jdk/jfr/events/SelectorSelectEvent.java line 44:

> 42:     @Label("SelectionKey Count")
> 43:     @Description("Number of channels ready for I/O or added to ready set")
> 44:     public int selectionKeyCount;

same here

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/16710#discussion_r1425754281
PR Review Comment: https://git.openjdk.org/jdk/pull/16710#discussion_r1425755618

Reply via email to