--------- - [x] I confirm that I make this contribution in accordance with the [OpenJDK Interim AI Policy](https://openjdk.org/legal/ai).
------------- Commit messages: - Replace RootedPath with ExplodedPath; replace Application.appDirSources() and Application.contentDirSources() with single Application.userContent() - PackagingPipelineTest: streamline - JUnitUtils: fix bugs in ExceptionPattern class; better test coverage; rename StringArrayConverter into ArrayConverter and make it more robust Changes: https://git.openjdk.org/jdk/pull/32664/files Webrev: https://webrevs.openjdk.org/?repo=jdk&pr=32664&range=00 Issue: https://bugs.openjdk.org/browse/JDK-8391713 Stats: 1293 lines in 26 files changed: 929 ins; 262 del; 102 mod Patch: https://git.openjdk.org/jdk/pull/32664.diff Fetch: git fetch https://git.openjdk.org/jdk.git pull/32664/head:pull/32664 PR: https://git.openjdk.org/jdk/pull/32664
