On Wed, 23 Sep 2026 18:24:59 GMT, Naoto Sato <[email protected]> wrote:

>> moseoh has updated the pull request incrementally with one additional commit 
>> since the last revision:
>> 
>>   Check names returned by concurrent first lookups
>
> test/jdk/sun/util/locale/provider/TimeZoneNameConcurrencyTest.java line 85:
> 
>> 83:                 try {
>> 84:                     barrier.await();
>> 85:                     tz.getDisplayName(false, TimeZone.SHORT, l);
> 
> I'd check the name returned by this `tz.getDisplayName()` call as well. The 
> current code may miss cases where this call returns an inconsistent name.

Good point, fixed. The test now checks each name returned by the worker threads.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/32867#discussion_r4089058772

Reply via email to