On Thu, 24 Sep 2026 19:42:00 GMT, Paul Sandoz <[email protected]> wrote:

>> Jatin Bhateja has updated the pull request incrementally with one additional 
>> commit since the last revision:
>> 
>>   Review comments resolution
>
> src/jdk.incubator.vector/share/classes/jdk/incubator/vector/X-Vector.java.template
>  line 1182:
> 
>> 1180:                     v0.bOp(v1, vm, (i, a, n) -> 
>> ($fallbacktype$)Integer.compress(a & LSHR_SETUP_MASK, n & LSHR_SETUP_MASK));
>> 1181:             case VECTOR_OP_EXPAND_BITS: return (v0, v1, vm) ->
>> 1182:                     v0.bOp(v1, vm, (i, a, n) -> 
>> ($fallbacktype$)Integer.expand(a & LSHR_SETUP_MASK, n & LSHR_SETUP_MASK));
> 
> Since `LSHR_SETUP_MASK` is now used in a different context we should rename 
> it? e.g. `ALL_BITS_MASK`?

Addressed

> test/jdk/jdk/incubator/vector/gen-template.sh line 450:
> 
>> 448: gen_binary_alu_op "XOR"   "a ^ b"   "BITWISE"
>> 449: gen_binary_alu_op "COMPRESS_BITS" "{#if[byteOrShort]?Integer.compress(a 
>> \& ((1 << \$Boxtype\$.SIZE) - 1), b \& ((1 << \$Boxtype\$.SIZE) - 
>> 1)):\$Boxtype\$.compress(a, b)}" "BITWISE"
>> 450: gen_binary_alu_op "EXPAND_BITS" "{#if[byteOrShort]?Integer.expand(a \& 
>> ((1 << \$Boxtype\$.SIZE) - 1), b \& ((1 << \$Boxtype\$.SIZE) - 
>> 1)):\$Boxtype\$.expand(a, b)}" "BITWISE"
> 
> Instead of such embedded expressions you can add compress/expand to the 
> relevant test class? Then the conditional is only whether  the qualifying 
> class is declared or not.

Addressed

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/33050#discussion_r4118858693
PR Review Comment: https://git.openjdk.org/jdk/pull/33050#discussion_r4118859156

Reply via email to