On Sat, Oct 15, 2016 at 2:55 AM, Pádraig Brady <p...@draigbrady.com> wrote:
> On 15/10/16 05:47, Jim Meyering wrote:
>> I tried to build the coreutils using very recent GCC 7, built from
>> latest git, and encountered a few new warnings (errors when configured
>> with --enable-gcc-warnings), so wrote the following to address them.
>> With these, everything now compiles warning free:
> All look good.
> I had a similar idea to die() with errorx() at:
The mixed semantics of "error" have been an annoyance for a long time.
Do you prefer the "errorx" name over "die"?
I have a slight preference for "die" because it is short and clear,
but perhaps more at risk of collision with existing name in some
project. When talking about this for grep, Paul proposed "dierror".
Eventually, we'd like to move this into gnulib, so coming up with a
good name is not an idle exercise.
> It seems like die() would be good in more cases.
> The two here:
> and the others noted by Bernhard:
Definitely useful in many other places. That would be good for a
follow-on patch. This one was focused on fixing warnings. I did not
want to dilute it with the global no-semantic-change patch to switch
to using "die" wherever possible.