Greetings.
I am trying to build rpms from the courier-imap 1.7.3 source. I am building
as a non-root user and have created a build environment and an .rpmmacro file
for this user as described in the FAQ. I'm on a stock install of red hat 9.0
and running postfix as my MTA. I execute the following command:
$ rpmbuild -ta --buildroot /home/courier/rpm courier-imap-1.7.3.tar.bz2
The sanity checks all fail with similar messages:
INFO: LOGIN, user=user, ip=[127.0.0.1]
ERR: Failed to create cache file: maildirwatch (user)
ERR: Error: Input/output error
ERR: Check for proper operation and configuration
ERR: of the File Access Monitor daemon (famd).
So, I am thinking that because the sanity check failure causes the build to
fail, I need to fiddle with the courier-imap.spec and change the parameters
for configure. Here's the ones generated from the default spec file:
./configure' --prefix=/usr/lib/courier-imap '--host=i686-pc-linux-gnu'
'--build=i686-pc-linux-gnu' '--target=i386-redhat-linux-gnu'
'--program-prefix=' '--prefix=/usr/lib/courier-imap'
'--exec-prefix=/usr/lib/courier-imap' '--bindir=/usr/lib/courier-imap/bin'
'--sbindir=/usr/lib/courier-imap/sbin'
'--sysconfdir=/usr/lib/courier-imap/etc'
'--datadir=/usr/lib/courier-imap/share'
'--includedir=/usr/lib/courier-imap/include'
'--libdir=/usr/lib/courier-imap/lib'
'--libexecdir=/usr/lib/courier-imap/libexec' '--localstatedir=/var/run'
'--sharedstatedir=/usr/lib/courier-imap/com'
'--mandir=/usr/lib/courier-imap/man' '--infodir=/usr/share/info'
'--with-authdaemonvar=/var/run/authdaemon.courier-imap'
'--enable-unicode=iso-8859-1,utf-8' 'CFLAGS=-O2 -g -pipe -march=i386
-mcpu=i686' 'build_alias=i686-pc-linux-gnu' 'host_alias=i686-pc-linux-gnu'
'target_alias=i386-redhat-linux-gnu'
--with-authchangepwdir=/usr/lib/courier-imap/libexec/authlib --with-db=gdbm
--with-userdb=/etc/userdb
--with-makedatprog='/usr/lib/courier-imap/libexec/makedatprog'
--with-mailuser=root --without-socks --with-authchangepwdir=/var/tmp/dev/null
--with-package=courier-imap --with-version=1.7.3 --cache-file=/dev/null
--srcdir=.
When I run configure from the command line, I get the following warnings:
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: ./configure
Given that the rpm build "saves you the headaches of manually compiling the
code..." (docs) I'm surprized that the generated configuration scripts are
not working for me.
Has anyone built rpms lately?
Anyone have a workaround or patch or suggestion? The FAQ and INSTALL files
don't give suggestions for failed rpm builds.
I'm hoping to avoid the painstaking trial-and-error approach to editing the
courier-imap.spec file to get the rpm to build. Better yet, how about some
binary rpms? ;)
Thanks for suggestions.
Jeff
-------------------------------------------------------
This SF.net email is sponsored by: eBay
Get office equipment for less on eBay!
http://adfarm.mediaplex.com/ad/ck/711-11697-6916-5
_______________________________________________
courier-users mailing list
[EMAIL PROTECTED]
Unsubscribe: https://lists.sourceforge.net/lists/listinfo/courier-users