Hello all! 

I think I messed something up during installation. 

After _make,_ _make install_ and setting module to load on system load,
there's a problem with _make check_. The error message indicates some
undefined references to libraries libcrypto and libssl. 

Library file is present in localization which is in the path
LD_LIBRARY_PATH. I run Ubuntu 14.04 with Linux kernel in
virtual machine. I have build-essential, kernel headers installed.

What I found, is that GCC should be invoked in specified order due to
dependancies. In this case: first object files, than -l with libraries
which contain definitions of functions which are called. So I invoked
gcc to link HMAC_COMP, HASH_COMP and CIPHER_COMP like this: 

> gcc hmac_comp.o openssl_wrapper.o -o hmac_comp -lssl -lcrypto

instead of 

> cc -lssl -lcrypto hmac_comp.o openssl_wrapper.o -o hmac_comp

from tests/Makefile (_make check_). 

It worked, make check could proceed.
Did anyone met the same problem? 

Cryptodev-linux-devel mailing list

Reply via email to