I now have a version of (long-term) Ubuntu partly working on my PC. But I still
have a partition mounting/using problem.

I apologise for the length and complexity of this message.

The machine was bought in 2020, and ctwm successfully ran on fedora until fedora
failed to allow zoom to run, and soon after that failed to allow my previous
usage of pulseaudio.

I tried using CentOS in a new partition, instead of fedora, because that's used
on our departmental machines, but it did not allow me to use zoom and later also
stopped supporting the pulseaudio facility I need. [I should probably have
emptied the CentOs partition before starting to install ubuntu.]

A colleague recommended lt-Ubuntu and I've downloaded an iso file that let me
install Ubuntu on a spare partition. I seemed to be using it successfully,
including getting sound when running firefox with BBC iplayer.

So I removed the usb stick with iso file and rebooted.

But Ubuntu was somehow using the CentOS partition and audio had stopped working.

After quite a lot of hassle using help/advice from a colleague I managed to
reboot again and got ubuntu running, but still using its own window manager
(very clumsy compared with ctwm).

After more hassle I managed to get ubuntu running with audio (e.g. bbc
iplayer working with sound in firefox), and I can now do quite a lot on ubuntu,
including using an xterm window to log through to my UoBirmingham PC running
CentOS on which I use the ctwm mailing list.

Eample: typing this message remotely

But there's still something wrong with my ubuntu installation, which at first I
thought might be corrupted bios, but I think it's more to do with how the bios
is configured (on a Gigabyte motherboard acquired in June 2020 -- has anyone
else on the ctwm list encountered it?).

Evidence for something wrong is that my Ubuntu system seems to be wrongly
mounted. If I type this in an xterm window (on my machine called chill):

  chill:~> cd /tmp
  chill:/> df -h .

I get

  Filesystem               Size  Used Avail Use% Mounted on
  /dev/mapper/centos-root   39G   16G   21G  43% /

Similarly if I change to my login directory

  cd ~axs

give the pwd command:

  chill:~> pwd

I get:


Then, to locate this on the filesystem 'df -h .'

  chill:~> df -h .


  Filesystem               Size  Used Avail Use% Mounted on
  /dev/mapper/centos-root   39G   16G   21G  43% /

I should not be using /centos-root for anything, since I had chosen a different
partition for installation of ubuntu!

Does this mean the ubuntu installer did something wrong?

Or was it merely a fault in the booting process?

If Ubuntu was installed in the wrong partition can I move it to the intended
partition, which I thought I had specified during the installation process? I
would prefer not to have to repeat the installation process.

[I need to keep available most of the stuff that I installed while running
fedora, and will eventually mount the required partitions -- at appropriate
mount points in the Ubuntu system, e.g. things like /usr/local/, places where
all the html etc. files for my web sites are stored locally (used by
remote-copying to departmental web directories as needed) and various backup

The task for my ctwm installation is to allow me to be working on files
scattered in different places and running programs, e.g. instatiations of
firefox showing different things, instantiations of my text editor (ved, in
Poplog, doing different tasks in different workspaces, and in some cases
running a process on a remote machine: e.g. I writing this message in an xterm
window at home logged through to a departmental machine where I can read and
send email messages, etc.) Sometimes one or more of my desktops or windows could
be accessed while giving a presentation in zoom. I don't get that convenience
from the Ubuntu default interface: what takes a fraction of a second in ctwm
would take much longer using the Ubuntu window manager.

Ctwm makes doing lots of work on different tasks over an extended period
more convenient than anything else I've tried, which is why I am so keen to get
this ubuntu system running properly, including ctwm.

So now I need help getting my new ubuntu system, in which I'm using ctwm,
installed at the right partition in the file system. [I presume an SSD is
preferable to a HDD partition, although other partitions of both types with
various contents going back decades, will be cross-mounted for easy access.]

My current home directory ~axs is, and will remain on another (i.e. non-root
partition, but mounted as /home/axs alongside other directories in /home.

Can anyone on this list recommend the best way to achieve the desired
configuration (using the version of ctwm provided by Ubuntu), and or explain how
I can undo the current mount of the wrong file system partition as my root

[I'll understand if anyone finds all that unintelligble...]


Reply via email to