(Apology to Mark: I sent this from the wrong address and the ctwm list
rejected it. So I am re-sending.)

Thanks Mark:

> How about trying to invoke the xterm from somewhere else?
> E.g., from another machine:
> ssh machine-running-ctwm   "export DISPLAY=":0"; xterm"
> This worked for me to display an xterm on another machine (but
> admittedly not running ctwm)

Yes it works!

One of the things I like about the version of ubuntu that I am running on chill
is that it allows me to ssh or scp between that machine and my other two
machines -- very old PC and newer (stonebook) laptop -- without hassles.

For some unknown reason, while running the recently installed fedora 37 on chill
I had problems with remote login and remote file transfer that I could not fix
by editing NetworkManager files and restarting.

So it would not have allowed me to use your method of launching xterm.
But Ubuntu on the same machine does not have that problem.

It won't help me to make use of the superficially attractive version of ctwm
that you found worked on Ubuntu, because it turned out that that does not make
use of an editable text file .ctwmrc, but something compiled, that can't be
changed. I was not previously aware that ctwm could be run that way.

But I'll try one of the other less attractive versions of .ctwmrc that I was
able to play with, and see if while using it I can use its limited multi desktop
functionality to let me do the editing needed to extend its functionality, since
I find the default desktop facilities on both fedora and Ubuntu dreadful to use.

It's going to strain this tired old brain, but may work if I can keep a clear


Reply via email to