Piotr Dobrogost wrote:
I'm annoyed by having to read (and soon write I hope)

SET(CMAKE_C_FLAGS "${CMAKE_ANSI_CFLAGS} ${CMAKE_C_FLAGS}")

instead of something like

SETPREPEND(CMAKE_C_FLAGS "${CMAKE_ANSI_CFLAGS}")

or

SET(CMAKE_C_FLAGS PREPEND "${CMAKE_ANSI_CFLAGS}")

Can we add macros for this and other similar things to make reading and
writing this code easier?


Hi Piotr,

I agree this is not the most readable thing of the world, but in another hand, 
a macro will not be very shorter. Anyway, I agree for SETPREPEND() / 
STRAPPEND() macros, since SET(... PREPEND) will not be more readable, IMHO.

--
Sukender
PVLE - Lightweight cross-platform game engine - http://pvle.sourceforge.net/

Reply via email to