Sukender wrote: > Hi Piotr, > > I agree this is not the most readable thing of the world, but in another > hand, a macro will not be very shorter. Anyway, I agree for SETPREPEND() > / STRAPPEND() macros, since SET(... PREPEND) will not be more readable, > IMHO.
It strikes me there is no support for managing lists with space separated elements in cmake. If they support lists with colon separated elements they should support the second kind as well. I raised this issue on cmake mailing list. You can read it here http://news.gmane.org/find-root.php?group=gmane.comp.programming.tools.cmake.user&article=20781 ${CMAKE_C_FLAGS} and such are lists in their nature and not single value variables. Thus they should be treated differently. I'd like to propose writing and using a set of macros handling lists with space separated elements in the same manner as existing LIST macros. What do you think? -- Piotr Dobrogost *** curlpp.org - c++ wrapper for libcurl ***
