Oh, I see the difference now. You basically use another construct to gather the 
(default) values. IMHO, my solution is much much clear because all variables 
which are read from rc.conf are in one single place and for beginners like me 
the script is easier to read.

Besides, you remove one variable (crtmpserver_config) and you put it's default 
value inside the required_files variable, but you add another one called 
pidfile.

Again, IMHO, my version is easier to read. It might be an overkill as you 
suggested, but I think that is a small price to pay and have the script is 
clear for newbies. Seeing all the rc.conf vars in one place is better than 
hunting them by eyeballing the file with care.

In any case, whatever you decide is good for me and it will be the template for 
the next revision.

Thank you for your time

On Jul 31, 2011, at 11:23 AM, Doug Barton wrote:

> On 07/31/2011 01:21, Doug Barton wrote:
>> +PORTVERSION=        1
> 
> Should be PORTREVISION, sorry.
> 
> 
> -- 
> 
>       Nothin' ever doesn't change, but nothin' changes much.
>                       -- OK Go
> 
>       Breadth of IT experience, and depth of knowledge in the DNS.
>       Yours for the right price.  :)  http://SupersetSolutions.com/
> 

------
C++ RTMP Server Support
Email: [email protected]
Web: http://www.rtmpd.com

Reply via email to