On Jul 31, 2011, at 11:48 AM, Doug Barton wrote:

> On 07/31/2011 01:34, C++ RTMP Server Support wrote:
>> Oh, I see the difference now. You basically use another construct to
>> gather the (default) values. IMHO, my solution is much much clear
>> because all variables which are read from rc.conf are in one single
>> place and for beginners like me the script is easier to read.
>> 
>> Besides, you remove one variable (crtmpserver_config) and you put
>> it's default value inside the required_files variable, but you add
>> another one called pidfile.
>> 
>> Again, IMHO, my version is easier to read. 
> 
> You still don't understand.
> 
> pidfile= is a requirement. As I said in my first message, it's special
> to rc.subr. This needs to be fixed.
> 
> As for how pidfile= and required_files= are set, that's a style issue
> that I'm less concerned about. What you are saying is that this is
> easier to read:
> 
> : ${name_config:=foo}
> : ${name_pidfile:=bar}
> 
> required_files=$name_config
> pidfile=$name_pidfile
> 
> What I'm saying is that doing it that way means that you're working
> harder than you have to. The way I had it in the patch means that each
> variable only has to be handled once. It may be slightly more difficult
> to read for novices, but it's not _that_ complex;
Well, is complex enough to discern if that variable is yours or needed by 
rc.subr
Maybe is as natural as breathing for trained people, but for us, newbies, is 
definitely not! :)
One simple comment line will most definitely save us A LOT of time :)

Here is the attached patch along with some comments :)
Tx for your time

Attachment: crtmpserver.patch
Description: Binary data

> and reduces the
> chances that a mistake will be made. However, if you choose not to use
> the style that I suggested, I'm not too concerned about that.
> 
> However, the pidfile issue has to be fixed.
> 
> 
> Doug
> 
> -- 
> 
>       Nothin' ever doesn't change, but nothin' changes much.
>                       -- OK Go
> 
>       Breadth of IT experience, and depth of knowledge in the DNS.
>       Yours for the right price.  :)  http://SupersetSolutions.com/
> 

------
C++ RTMP Server Support
Email: [email protected]
Web: http://www.rtmpd.com

Reply via email to