I updated my cygwin the other day, as I periodically do, and I am very
sorry I did so.  Here are some of the problems I have encountered.

1) Couldn't start cygwin X at all.  The link on my desktop pointed to
a script (which I had customized) in /usr/X11R6/bin, which was deleted
by the upgrade.  It took me a while to find the replacement --
mysteriously moved to /usr/bin, minus my customizations.

2) Fonts I had added no longer work.  Everything looks fine in
/usr/X11R6/lib/X11/fonts.  Messed around there for a while, to no
avail.  After much Googling, found that the fonts have been moved to
/usr/share/fonts.

3) While trying to figure out why my fonts weren't working, I
naturally tried to use xfontsel.  "bash: xfontsel: command not found".
 WHAT?!  It turns out that it's now in its own cygwin package, as are
about a billion other useful utilities that have been deleted without
warning.

4) xterms all now have a useless, annoying menu at the top.  I want to
make it go away.  Had to wade through the xterm manual to learn that
this is apparently called a "toolbar" and is now on by default.

I am extremely annoyed.  I have lost many hours of productivity just
trying to get back to where I was on Monday, and I'm still not there.
The worst part of it is that I (and probably most cygwin users out
there) was completely blindsided, and there was no post-upgrade help
to be found.  What's on the "news" page at cygwin.com?  A kernel
upgrade in June.  Before that, a kernel upgrade in May, and one in
March. Nothing new in the FAQ.  No announcement of a change that's
going to screw up your whole system.

At x.cygwin.com, things are even worse. "Last updated: 2004-01-10 0200
EST (Harold L Hunt II)".  Not helpful.  There is a short note at the
bottom of the main page directing people to the mailing list
announcement. It contains useful information such as "before you
upgrade, do this and that and the other thing".  Wish I had known
about some of those before I upgraded!  It also notes without
explanation that most programs are in their own packages now.  This is
terribly inconvenient to us ordinary users.

My xterms are screwed up.  Numlock is very wonky:  Let's say I start
off with numlock on; I am in a Windows (non-X) window; I switch to an
xterm; I use the numeric keypad to type; I get nothing (tildes, escape
codes, non-numlock crap).  I switch to another xterm, I type on the
keypad, I get digits.  I switch back to the first xterm, it's still
acting as though numlock is off.  I switch to a Windows window, then
back to the first xterm.  Now it behaves as though numlock is on.  I
switch to the second xterm window, *it* is behaving as though numlock
is off.  All this time, the numlock LED is lit.  I can consistently
repeat this.

xfontsel is broken.  The main part of the window does not redraw
itself when dropdown menus disappear, so you wind up with large
portions of old menus cluttering the client area.  Several of the
fonts are rendered with a broken, crappy look.  As far as I can tell,
this is not a problem with the font iself -- but who knows!

I am sure that the cygwin X developers put a great deal of time and
effort into this upgrade.  And I honestly appreciate the work that
they do.  Being a contributor to open-source software myself, I can
appreciate what they go through.  But this upgrade was surely poorly
thought-out.  I am not a cygwin developer; I am not really even a
cygwin power user, although I will not -- cannot -- use Windows
without cygwin.  So I am not subscribed to the cygwin mailing lists.
I just run setup.exe periodically to get patches.  It should not have
re-architected my whole damn system without warning.

Eric

--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Reply via email to