Dear Cygwin maintainer

Since last X-Cygwin update several of my X-Win applications are not working properly.

Googling "cygwin xorg 1.17 crash" gave many posts reporting probably similar issues but I couldn't find a fix for the error. I also looked at the Cygwin-FAQ and mailing list without real success.

The issue appeared using a long-time tested DOS script launching xmgrace which failed with a message telling "A fatal error has occurred and Cygwin/X will now exit." And other XWin programs were not working properly. So I tried to make a fresh install of X-Cygwin (32 bits) on another computer and went through the procedure explained on page

http://x.cygwin.com/devel/backtrace.html

which produced the debug info attached as "backtrace for X server crashing at startup.txt". The X Server crashed when the r command was launched and a copy of the Windows error message is provided at "Capture of Windows error message.txt". I checked that no other X Server was then running and clicked Ok button to finish the procedure.

The content of the file /var/log/xwin/XWin.0.log is listed at the end of the first attached file.

I also tried to install the most recent xlaunch program as suggested here

https://www.cygwin.com/ml/cygwin-xfree/2015-02/msg00089.html

but it did not solve the issue.

Sorry for asking something that might be FAQ but as I told I could not find a clear answer elsewhere and indeed xlaunch reproduced the error consistently.

Thanking you in advance for your assistance, and of course for providing this invaluable software that is cygwin.

Regards

--
Michel Poirier
CEA, IRAMIS
Laboratoire Interactions, Dynamique et Lasers
Centre d'Études de Saclay, bât. 522
F91191 Gif/Yvette (France)

Tél.  : +33 1 69 08 46 29
FAX   : +33 1 69 08 87 07
e-mail: michel.poir...@cea.fr

IRAM-FA-004439+admin-local@IRAM-FA-004439 ~
$ gdb --args /usr/bin/XWin -multiwindow
GNU gdb (GDB) 7.8
Copyright (C) 2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-cygwin".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from /usr/bin/XWin...Reading symbols from /usr/lib/debug//usr/bi
n/XWin.exe.dbg...Can't read data for section '.debug_frame' in file '/usr/lib/de
bug/usr/bin/XWin.exe.dbg'
(gdb) handle SIGSYS nostop
Signal        Stop      Print   Pass to program Description
SIGSYS        No        Yes     Yes             Bad system call
(gdb) r
Starting program: /usr/bin/XWin -multiwindow
[New Thread 5852.0xc88]
[New Thread 5852.0x1a0c]
[New Thread 5852.0xcec]
[New Thread 5852.0x1548]
[New Thread 5852.0x50c]
[New Thread 5852.0x4e0]
[Thread 5852.0x4e0 exited with code 1]
[Thread 5852.0x1a0c exited with code 1]
[Thread 5852.0x50c exited with code 1]
[Thread 5852.0xcec exited with code 1]
[Inferior 1 (process 5852) exited with code 01]
(gdb) bt full
No stack.
(gdb) q

IRAM-FA-004439+admin-local@IRAM-FA-004439 ~
$ cat /var/log/xwin/XWin.0.log
Welcome to the XWin X Server
Vendor: The Cygwin/X Project
Release: 1.17.1.0
OS: CYGWIN_NT-6.1-WOW IRAM-FA-004439 1.7.35(0.287/5/3) 2015-03-04 12:07 i686
OS: Windows 7 Service Pack 1 [Windows NT 6.1 build 7601] (WoW64)
Package: version 1.17.1-2 built 2015-02-23

XWin was started with the following command line:

/usr/bin/XWin -multiwindow

ddxProcessArgument - Initializing default screens
winInitializeScreenDefaults - primary monitor w 1920 h 1200
winInitializeScreenDefaults - native DPI x 96 y 96
_XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
(EE) Fatal server error:
(EE) Cannot establish any listening sockets - Make sure an X server isn't alread
y running(EE)
[ 17451.691] (EE) Server terminated with error (1). Closing log file.
A fatal error has occurred and Cygwin/X will now exit.



Cannot establish any listening sockets - Make sure an X server isn't already 
running



Please open /var/log/xwin/XWin.0.log for more information.



Vendor: The Cygwin/X Project
Release: 1.17.1.0

Contact: cygwin-xfree@cygwin.com

Package: version 1.17.1-2 built 2015-02-23



XWin was started with the following command-line:

/usr/bin/XWin -multiwindow 
--
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
Problem reports:       http://cygwin.com/problems.html
Documentation:         http://x.cygwin.com/docs/
FAQ:                   http://x.cygwin.com/docs/faq/

Reply via email to