On 10/13/2016 08:20 PM, Bron Gondwana via Cyrus-devel wrote:
On Fri, 14 Oct 2016, at 12:08, Jan Parcel via Cyrus-devel wrote:
On 10/13/2016 03:23 PM, ellie timoney via Cyrus-devel wrote:
I think some of the confusion comes from the fact that the setting name -- "archive max size" -- very strongly implies (incorrectly) something like "the largest size of message that will be archived" / "messages larger than this will not be archived at all". It takes a fair bit of attentive reading to overcome that initial implication and reach the correct understanding, that "messages larger than this will be archived immediately, without waiting for archive_days".

But I haven't thought of a better name for this setting either.
My training is originally in both software engineering and Technical Communications and this sounds like a REALLY good argument for changing the name of the setting. "max_size_delayed_archive" -- where are they held if not archived immediately? "max_size_cached_before_archiving" ?

Yeah, I agree it's a kind of crappy name. I honestly don't care what colour this particular bikeshed gets painted. Pull requests at https://github.com/cyrusimap/cyrus-imapd/ gratefully received.

Actually, I want to pull libsasl, but I don't know how to turn it into a tarball so I can test it. Or how to get permission to push.

And if I can change that name for y'all on a weekend, I guess I could do it.

(feel free to come up with a better name for 'proxyservers' while you're thinking about config naming, though that has a much larger entrenched installed base)


  Bron Gondwana

Reply via email to