Hey.
I got some segfaults today when trying to adjust the temperature, and started running in gdb.
For some reason adjusting temperature worked, but after a while I got

Thread 8 "darktable" received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffd2ae1700 (LWP 11606)]
0x00007fffaa37c71b in demosaic_ppg (thrs=0, filters=<optimized out>, roi_in=0x7fffd2ad0e10, roi_out=0x7fffd2ad0e30, in=<optimized out>, out=0x0)
    at /build/darktable-lL6Etk/darktable-2.2.5/src/iop/demosaic.c:1327

Here's part of the stacktrace in case that helps:
#0 0x00007fffaa37c71b in demosaic_ppg (thrs=0, filters=<optimized out>, roi_in=0x7fffd2ad0e10, roi_out=0x7fffd2ad0e30, in=<optimized out>, out=0x0)
    at /build/darktable-lL6Etk/darktable-2.2.5/src/iop/demosaic.c:1327
#1 0x00007fffaa37c71b in process (self=<optimized out>, piece=<optimized out>, i=<optimized out>, o=<optimized out>, roi_in=<optimized out>, roi_out=<optimized out>)
    at /build/darktable-lL6Etk/darktable-2.2.5/src/iop/demosaic.c:1702
#2 0x00007ffff7a39ac8 in _default_process_tiling_roi (self=0x555556b5faf0, piece=0x7fffc0002530, ivoid=0x7fff3de4b010, ovoid=0x7fff10649010, roi_in=0x7fffd2ad1310, roi_out=<optimized out>, in_bpp=4)
    at /build/darktable-lL6Etk/darktable-2.2.5/src/develop/tiling.c:1107
#3 0x00007ffff7a1a56f in dt_dev_pixelpipe_process_rec (pipe=pipe@entry=0x555556270fb0, dev=dev@entry=0x555556210cd0, output=output@entry=0x7fffd2ad16d8, cl_mem_output=cl_mem_output@entry=0x7fffd2ad16e0, out_format=out_format@entry=0x7fffd2ad16e8, roi_out=roi_out@entry=0x7fffd2ad1710, modules=0x555556153360 = {...}, pieces=0x555557a68e40 = {...}, pos=8)

Any help / fixes would be much appreciated.

Cheers,
Andy
____________________________________________________________________________
darktable user mailing list
to unsubscribe send a mail to darktable-user+unsubscr...@lists.darktable.org

Reply via email to