On Mon, Dec 15, 2008 at 11:13:40AM -0800, David Brownell wrote:
> On Monday 15 December 2008, Felipe Balbi wrote:
> > From: Felipe Balbi <[email protected]>
> > 
> > It's easier to follow and to maintain.
> > 
> > ...
> > +static void davinci_mmc_read_fifo(struct mmc_davinci_host *host,
> > +           u16 len, u8 *dest)
> > +{
> > +   void __iomem *fifo = host->base + DAVINCI_MMCDRR;
> > +   u16 index = 0;
> > +
> > +   dev_dbg(mmc_dev(host->mmc), "RX fifo %p count %d buf %p\n",
> > +                   fifo, len, dest);
> > +
> > +   if (likely((0x03 & (unsigned long) dest) == 0)) {
> > +           if (len >= 4) {
> > +                   readsl(fifo, dest, len >> 2);
> 
> Actually I think the new way to spell readsl() is ioread32_rep().
> More portable, more clear.

cool, will fix :-)

good catch with the missing branch, thanks

-- 
balbi

_______________________________________________
Davinci-linux-open-source mailing list
[email protected]
http://linux.davincidsp.com/mailman/listinfo/davinci-linux-open-source

Reply via email to