Felipe Balbi wrote: > From: Felipe Balbi <[email protected]> > > It's easier to follow and to maintain. > > Signed-off-by: Felipe Balbi <[email protected]> > --- > drivers/mmc/host/davinci_mmc.c | 122 > +++++++++++++++++++++------------------- > 1 files changed, 64 insertions(+), 58 deletions(-) > >
You need to post performance tests pre and post patch to let us know how much this degrades performance. Remember to turn off dma before the test. I personally don't like this patch. But I'm biased, as I added the assembly fifo access in the first place. The description should also be improved. More like, "replace assembly language with similar C code" Troy _______________________________________________ Davinci-linux-open-source mailing list [email protected] http://linux.davincidsp.com/mailman/listinfo/davinci-linux-open-source
