On Sun, Jun 30, 2002 at 08:30:31PM -0500, Paul DuBois wrote: > At 23:32 +0100 6/30/02, Tim Bunce wrote: > >On Sun, Jun 30, 2002 at 10:43:19AM -0700, Michael A Chase wrote: > >> On Sun, 30 Jun 2002 11:48:49 -0500 Paul DuBois <[EMAIL PROTECTED]> wrote: > >> > >> > At 16:23 +0100 6/30/02, Tim Bunce wrote: > >> > >Support for cancel was added in DBD::Oracle 1.09 thanks to a patch > >> > >from Fredrik Sjoholm. > >> > > >> > Will cancel eventually become the general preferred replacement for > >> > finish for early termination of result set fetching operations? > >> > >> No. > >> > >> finish() is a hint to DBI that the query will not be fetched from again. > >> The hint may be passed along to the databse to allow it to release > >> resources being held for the statement. > >> > >> cancel(), when it works, tells the database to abort the current operation. > > > >Spot on. > > > >I'll probably rename finish() to something like discard_unfetched_rows(). > >(Keeping an alias for old code of course.) > > I guess I got the idea from this sentence in perldoc DBI: > > The `finish' method should have been called `cancel_select'.
I keep changing what I want to rename it to - which is why I haven't renamed it yet :) I think discard_unfetched_rows is the most descriptive and least ambiguous one I've come up with yet. Tim.