Hi all,
I have installed Deal II 8.5 and trunk versions on Daint (the CSCS 
machine). When I run the example step-5 with PETSc I have the following 
Running using PETSc.
Cycle 0:
   Number of degrees of freedom: 659 (578+81)
| Total wallclock time elapsed since start    |     0.354s |            |
|                                             |            |            |
| Section                         | no. calls |  wall time | % of total |
| assembly                        |         1 |      0.14s |        40% |
| setup                           |         1 |    0.0873s |        25% |
| solve                           |         1 |     0.365s |     1e+02% |
ERROR: Uncaught exception in MPI_InitFinalize on proc 0. Skipping 
MPI_Finalize() to avoid a deadlock.
Exception on processing: 
An error occurred in line <66> of file 
</project/csstaff/nfadel/dealii/source/lac/petsc_precondition.cc> in 
const dealii::PETScWrappers::VectorBase&) const
The violated condition was: 
    pc != nullptr
Additional information: (none)
[0]PETSC ERROR: #1 PetscCommDestroy() line 214 in 
[0]PETSC ERROR: #2 PetscHeaderDestroy_Private() line 116 in 

on github I found the issue "step-55 PETSc fails #4150" already solved but 
it seems not the same problem.

I reproduce the crash both in serial and parallel, while trilinos works 

The error is caught when Deal II checks if the pointer to preconditioner 
object's pc is a NULL.
AssertThrow (pc != nullptr, StandardExceptions::ExcInvalidState ());

It happens when the minres solver does:
 precondition.vmult (v,*u[1]);

Do you have any hint how to fix it?

Thank you in advance!

The deal.II project is located at http://www.dealii.org/
For mailing list/forum options, see 
You received this message because you are subscribed to the Google Groups 
"deal.II User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to dealii+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to