On Sunday, March 11, 2018 at 9:27:40 AM UTC-4, Marquito Forrest wrote:
> In summary the situation is:
> - Debian testing image (to get recent gcc)
> - Miniconda Python 3.6 (my own Dockerfile, cf. file 1)
> - Latest spack from github (another Dockerfile derived from file 1, cf. 
> file 2)
> - Then in a bash I ran "spack install dealii -trilinos -oce ^cmake@3.9.4"
>      Since PETSc failed to build some FORTRAN specific stuff (f90-mod) and 
> I assumed we don't need any FORTRAN bindings
>      I ran "spack edit petsc" and set "--with-fc=0", which led to a 
> successful compilation of PETSc.
>      At last the dealii compilation failed but I was not able to deduce 
> any logical steps to take from the error messages.
A few things:
1) there is a binary available for Mac see here
2) there are people installing deal.II with spack on mac so you may want to 
post your problem here so we can help you
3) we have several docker images on dockerhub see deal.ii/full-depends was updated two days 
ago so you may want to give it a try. If you want to have your own 
Dockerfile, I suggest that you take a look at ours here
4) your installation fails with this error: 
       g++: internal compiler error
    this happens when you don't have enough ram. Try using less processors. 
You are using 4 right now, try with one.



The deal.II project is located at
For mailing list/forum options, see
You received this message because you are subscribed to the Google Groups 
"deal.II User Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
For more options, visit

Reply via email to