Your message dated Fri, 6 Apr 2018 16:22:29 +0100
with message-id <f216b0c5-5170-b6c0-c0a2-8b26bb64b...@debian.org>
and subject line Re: Bug#895016: soundconverter: Soundconverter AssertionError
has caused the Debian Bug report #895016,
regarding soundconverter: Soundconverter AssertionError
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
895016: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=895016
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: soundconverter
Version: 3.0.0-1
Severity: important

Dear Maintainer,

Soundconverter does not load, showing an AssertionError and crashing.

I've tested the stable, testing and sid versions and all them chrashed. Maybe
the error was caused by any dependency I'm not able to find.

Here the output:

$ → soundconverter
SoundConverter 3.0.0
Traceback (most recent call last):
  File "/usr/bin/soundconverter", line 161, in <module>
    _check_libs()
  File "/usr/bin/soundconverter", line 75, in _check_libs
    from gi.repository import Gst
  File "<frozen importlib._bootstrap>", line 971, in _find_and_load
  File "<frozen importlib._bootstrap>", line 955, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 656, in _load_unlocked
  File "<frozen importlib._bootstrap>", line 626, in _load_backward_compatible
  File "/usr/lib/python3/dist-packages/gi/importer.py", line 146, in
load_module
    dynamic_module = load_overrides(introspection_module)
  File "/usr/lib/python3/dist-packages/gi/overrides/__init__.py", line 125, in
load_overrides
    override_mod = importlib.import_module(override_package_name)
  File "/usr/lib/python3.6/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "/usr/lib/python3/dist-packages/gi/overrides/Gst.py", line 581, in
<module>
    real_functions = [o for o in inspect.getmembers(Gst) if isinstance(o[1],
type(Gst.init))]
  File "/usr/lib/python3.6/inspect.py", line 342, in getmembers
    value = getattr(object, key)
  File "/usr/lib/python3/dist-packages/gi/module.py", line 155, in __getattr__
    assert g_type == TYPE_NONE
AssertionError


Thanks!



-- System Information:
Debian Release: buster/sid
  APT prefers testing
  APT policy: (500, 'testing'), (500, 'stable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.14.0-6.1-liquorix-amd64 (SMP w/4 CPU cores; PREEMPT)
Locale: LANG=es_ES.utf8, LC_CTYPE=es_ES.utf8 (charmap=UTF-8), 
LANGUAGE=es_ES.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages soundconverter depends on:
ii  dconf-gsettings-backend [gsettings-backend]  0.26.1-3
ii  gir1.2-glib-2.0                              1.56.0-2
ii  gir1.2-gstreamer-1.0                         1.12.4-1
ii  gir1.2-gtk-3.0                               3.22.29-2
ii  gstreamer1.0-plugins-base                    1.14.0-dmo1
ii  gstreamer1.0-plugins-good                    1.12.4-1+b1
ii  python3                                      3.6.4-1
ii  python3-gi                                   3.28.1-1

Versions of packages soundconverter recommends:
ii  gir1.2-notify-0.7          0.7.7-3
ii  gstreamer1.0-libav         1:1.14.0-dmo1
ii  gstreamer1.0-plugins-ugly  1:1.14.0-dmo1

soundconverter suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
On 06/04/18 16:19, jEsuSdA 8) wrote:
> El 06/04/18 a las 12:36, James Cowgill escribió:
>> Control: tags -1 moreinfo
>>
>> Hi,
>>
>> On 06/04/18 11:06, jesusda wrote:
>>> Package: soundconverter
>>> Version: 3.0.0-1
>>> Severity: important
>>>
>>> Dear Maintainer,
>>>
>>> Soundconverter does not load, showing an AssertionError and crashing.
>>>
>>> I've tested the stable, testing and sid versions and all them
>>> chrashed. Maybe
>>> the error was caused by any dependency I'm not able to find.
>> [...]
>>> Versions of packages soundconverter depends on:
>>> ii  dconf-gsettings-backend [gsettings-backend]  0.26.1-3
>>> ii  gir1.2-glib-2.0                              1.56.0-2
>>> ii  gir1.2-gstreamer-1.0                         1.12.4-1
>>> ii  gir1.2-gtk-3.0                               3.22.29-2
>>> ii  gstreamer1.0-plugins-base                    1.14.0-dmo1
>> Try installing all gstreamer related packages from the official Debian
>> repositories instead of from deb-multimedia.org.
>>
>> James
>>
> Updating **ALL**  the **GSTREAMER PYTHON**  packages solves the issue.
> 
> Sorry. ;)

Thanks - closing the bug in that case.

James

Attachment: signature.asc
Description: OpenPGP digital signature


--- End Message ---

Reply via email to