On 11/10/16 10:16, Brian Potkin wrote:
> On Mon 10 Oct 2016 at 18:41:46 +0200, Daniel Pocock wrote:
>> On 10/10/16 18:24, Didier 'OdyX' Raboud wrote:
>>> Control: tags -1 +moreinfo
>>> Hi Daniel,
>>> Le lundi, 10 octobre 2016, 18.15:15 h CEST Daniel Pocock a écrit :
>>>> hpcups[16590]: prnt/hpcups/HPCupsFilter.cpp 707: First raster data plane..
>>>> hp[16592]: io/hpmud/jd.c 820: mdns lookup ABC123DEF.local retry 1...
>>>> (…)
>>>> hp[16592]: io/hpmud/jd.c 820: mdns lookup ABC123DEF.local retry 20...
>>>> hp[16592]: io/hpmud/jd.c 816: error timeout mdns lookup ABC123DEF.local
>>> It looks like you have experienced some ZeroConf hiccup, wich your mdns 
>>> failing to resolve 'ABC123DEF.local' for some time, and letting the address 
>>> resolution timeout.
>> Yes, the same log entries appeared each time I re-enabled the printer.
>> It tried for 20 seconds and then gave up and disabled the printer again.
>>> I don't really see how a complex backend/networking(/WiFi 
>>> ?)/autoconfiguration 
>>> bug could be better handled. If it's misterious for you and me, I don't see 
>>> how CUPS is supposed to handle and interpret HPLIP-specific stderror 
>>> daemon.log 
>>> output.
>>> This really looks like a one-time network hiccup; it could also be a 
>>> problem 
>>> in HPLIP, or in avahi.
>> I'm guessing that the problem will probably go away after a reboot, but
>> I don't like telling users that they need to reboot Debian to fix
>> things.  I did try rebooting the printer though and that didn't help.
>> I'm not familiar with HPLIP or avahi, would you know anybody who could
>> comment on this or suggest further details I should obtain from the
>> system before it is rebooted?
> Please do
>   avahi-browse -art > filename
> and post filename. avahi-browse is in the avahi-utils package.
> Also post the outputs of
>   /usr/sbin/lpinfo -v
>   /usr/lib/cups/backend/snmp
>   ping -c3 ABC123DEF.local

I found out that the root cause appeared to be a firewall change that
was specifically blocking the mDNS stuff while other things still
worked, I commented on it in this reply on debian-printing:


Is there anything the avahi tools can do in scenarios like this to
provide more information through the printing diagnostic wizard?



Reply via email to