[ FTR: resending to the bug ]

Subject: Re: Bug#822434: patch for building 8.0.27-1, based on 7.5.18-2
Date: Wed, 12 Oct 2016 00:06:19 +0200
From: Andreas Beckmann <a...@debian.org>
To: Debian NVIDIA Maintainers <pkg-nvidia-de...@lists.alioth.debian.org>

On 2016-10-11 21:56, Graham Inggs wrote:
> Hi lumin, Andreas
> 
> On 7 October 2016 at 17:24, lumin <cdlumin...@gmail.com> wrote:
>> I downloaded the tarball, and I may hopefully finish the patchset
>> within a week or two. Is this acceptable for Ubuntu freeze exception?
> 
> I've managed to get a Feature Freeze Exception (LP: #1630162) [1], but
> Yakkety releases on Thursday [2], so that leaves us with very little
> time.  I think if we can get something into SVN within the next 24
> hours, I can upload that directly to Ubuntu as 8.0.44-0ubuntu1.

It's mainly the new packages missing from debian/control (I didn't want
to commit the FIXME descriptions) and their .install files. Lintian
overrides and symbols files are already in place, and you should be able
to build packages for testing reverse dependencies even without having
the new packages.

Which compilers will be in yakkety? gcc-4.8/4.9/5?

> I did the same for 7.5.18-0ubuntu1 for the Xenial release, but I was
> able to grab the orig.tar from SVN [4].
> I don't see the 8.0.44 tarball there yet, so I hope the tarball
> generation is deterministic, or else we just need to make sure we
> upload the same tarball to Debian as we do to Ubuntu.

Generation should be deterministic (unless nvidia changes something on
their download servers, updating timestamps will break determinism)
I just committed the ones we have now, to be sure we use the same ones.

I only tested building the packages on amd64 and ppc64el, but did not
test them (or the rdepends) at all.


Andreas

Reply via email to