On 12/10/16 08:26, Daniel Kahn Gillmor wrote:
> Control: tags 800032 + moreinfo unreproducible
> Hi Ondřej--
> Sorry for taking so long to respond to this.  A few questions below:

Hi Daniel,
thanks for looking into this, although I'm not sure yet what exactly is
going on there yet, I think you're onto something.

> [...]
> Is this still happening for you?  Do you have dbus installed?  is there
> a dbus session running?  Is there a query on the dbus user session for
> any particular service?

For all of the above I'd say yes, maybe apart from the query,
dbus-monitor doesn't say anything even though I can see dbus-daemon
starting new processes. It might be that I'm not passing it the options
to actually show that, do you know how to get it to display them?

> I've seen reports of timeouts of ~30s before
> waiting for some "org.a11y.Bus" service to respond.  Some of those
> reports were cleared up with the installation or removal of the
> at-spi2-core package, but i haven't been able to reproduce it myself.
> Do you have at-spi2-core installed?  if so, what version?

The package at-spi2-core is installed (the version currently in
stretch), as it is depended on by gnome-core, I've not tried
uninstalling it yet and hitting reinstall in aptitude has not changed
the behaviour.

One thing that does come up, though, is when I run process monitoring,
pinentry-gtk-2 is started by gpg-agent, then dbus-daemon starts
/usr/lib/at-spi2-core/at-spi-bus-launcher, that exits, then dbus starts
gnome-keyring-daemon. Will try to change the monitor to give timings as
well but kworker storms tend to fill the netlink socket before I get to
the timeout so I'm trying to keep the monitoring tool as simple as I can
at the moment.

Hmm, for some reason I have two dbus-daemons running and the one started
by ck-launch-session is the one where pinentry is having problems.


Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to