Package: firefox
Version: 55.0-2
Severity: wishlist

I've noticed that firefox 55.0-2 takes much more memory on disk than
firefox 54.0-2 (155107 KB vs 108884 KB). Looking at the deb files,
this partly comes from the fact that the omni.ja files were compressed
in FF 54, but this is no longer the case in FF 55 (a total difference
of 27 MB). This is probably due to the upstream change discussed in

  https://bugzilla.mozilla.org/show_bug.cgi?id=1362377

(RESOLVED FIXED in Firefox 55), and it appears that this wasn't done
on purpose in the Debian build (nothing in the changelog.Debian file).

It seems that there were two reasons for this change upstream:

1. Reduce the download size for partial updates.

2. Possibly reduce the startup time.

However, for Debian, (1) doesn't apply since updates are provided
only by its package system.

Concerning (2), this is unclear, even for upstream. See in particular
Comment 3:

  https://bugzilla.mozilla.org/show_bug.cgi?id=1362377#c3

Also, the telemetry tests were done on MS Windows (yes, for their
global choices, upstream favors MS Windows).

So, unless it is shown that there is a clear improvement for the
(cold and/or warm) startup time, it may be better to revert this
change for Debian, i.e. re-enable omni.ja compression.

-- Package-specific info:

-- Extensions information
Name: -Global Styles- userstyle
Status: enabled

Name: Adblock Plus
Location: ${PROFILE_EXTENSIONS}/{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}.xpi
Status: enabled

Name: AlloCiné userstyle
Status: enabled

Name: allocine-imdb greasemonkey-user-script
Status: enabled

Name: Application Update Service Helper
Location: ${PROFILE_EXTENSIONS}/aushel...@mozilla.org.xpi
Status: enabled

Name: cac-imdb greasemonkey-user-script
Status: enabled

Name: Cinémathèque Française userstyle
Status: enabled

Name: Classic Theme Restorer
Location: ${PROFILE_EXTENSIONS}/classicthemeresto...@arist2noia4dev.xpi
Status: enabled

Name: Combine Stop/Reload buttons userstyle
Status: enabled

Name: Config Descriptions
Location: ${PROFILE_EXTENSIONS}/{1823e248-6bf4-f6f1-7901-65a68e8b6c1e}.xpi
Status: enabled

Name: Default theme
Location: 
/usr/lib/firefox-esr/browser/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}.xpi
Package: firefox-esr
Status: enabled

Name: Dictionnaire français dictionary
Location: ${PROFILE_EXTENSIONS}/fr-dicolle...@dictionaries.addons.mozilla.org
Status: enabled

Name: Different cursor for links that open in new windows userstyle
Status: enabled

Name: Disable autocomplete userstyle
Status: user-disabled

Name: Disable marquee userstyle
Status: user-disabled

Name: Filmsite.org userstyle
Status: enabled

Name: Firebug
Location: ${PROFILE_EXTENSIONS}/fire...@software.joehewitt.com.xpi
Status: enabled

Name: Flagfox
Location: ${PROFILE_EXTENSIONS}/{1018e4d6-728f-4b20-ad56-37578a4de76b}.xpi
Status: enabled

Name: FlashStopper
Location: ${PROFILE_EXTENSIONS}/flashstop...@byo.co.il.xpi
Status: enabled

Name: Font Finder
Location: ${PROFILE_EXTENSIONS}/{a658a273-612e-489e-b4f1-5344e672f4f5}.xpi
Status: enabled

Name: FxIF
Location: ${PROFILE_EXTENSIONS}/{11483926-db67-4190-91b1-ef20fcec5f33}.xpi
Status: enabled

Name: Gecko Profiler
Location: ${PROFILE_EXTENSIONS}/jid0-edalmuivkozlouyij0lpdx54...@jetpack.xpi
Status: user-disabled

Name: GLPI - assistance.ens-lyon.fr userstyle
Status: enabled

Name: Google Search userstyle
Status: enabled

Name: Greasemonkey
Location: ${PROFILE_EXTENSIONS}/{e4a8a97b-f2ed-450b-b12d-ee082ba24781}.xpi
Status: enabled

Name: gtranslate
Location: ${PROFILE_EXTENSIONS}/{aff87fa2-a58e-4edd-b852-0a20203c1e17}.xpi
Status: enabled

Name: HeadingsMap
Location: ${PROFILE_EXTENSIONS}/headi...@niquelheadings.net.xpi
Status: enabled

Name: HTML5 Video Everywhere!
Location: ${PROFILE_EXTENSIONS}/html5-video-everywh...@lejenome.me.xpi
Status: enabled

Name: IMDb userstyle
Status: enabled

Name: itt-datetimes greasemonkey-user-script
Status: enabled

Name: Link Widgets
Location: ${PROFILE_EXTENSIONS}/linkwid...@clav.mozdev.org
Status: enabled

Name: Live HTTP headers
Location: ${PROFILE_EXTENSIONS}/{8f8fe09b-0bd3-4470-bc1b-8cad42b8203a}
Status: enabled

Name: Move tabbar to the bottom userstyle
Status: user-disabled

Name: Move tabbar to the left userstyle
Status: user-disabled

Name: Move tabbar to the right userstyle
Status: user-disabled

Name: Multi-process staged rollout
Location: ${PROFILE_EXTENSIONS}/e10sroll...@mozilla.org.xpi
Status: enabled

Name: Multiple row bookmark toolbar userstyle
Status: user-disabled

Name: Nerim userstyle
Status: enabled

Name: Nimbus Screen Capture - editable screenshots.
Location: ${PROFILE_EXTENSIONS}/nimbusscreencaptur...@everhelper.me.xpi
Status: enabled

Name: Open in Browser
Location: ${PROFILE_EXTENSIONS}/openinbrow...@www.spasche.net.xpi
Status: enabled

Name: PeopleForCinema userstyle
Status: enabled

Name: Pocket
Location: ${PROFILE_EXTENSIONS}/fire...@getpocket.com.xpi
Status: enabled

Name: QuickWiki
Location: ${PROFILE_EXTENSIONS}/{EE223D7A-F30F-11DD-8F0A-D2AD55D89593}.xpi
Status: enabled

Name: Slashdot.org - Remove ads userstyle
Status: enabled

Name: SourceForge font size in comments userstyle
Status: enabled

Name: Stylish
Location: ${PROFILE_EXTENSIONS}/{46551EC9-40F0-4e47-8E18-8E5CF550CFB8}.xpi
Status: enabled

Name: Tab Mix Plus
Location: ${PROFILE_EXTENSIONS}/{dc572301-7619-498c-a57d-39143191b318}.xpi
Status: enabled

Name: twitter-times greasemonkey-user-script
Status: enabled

Name: us-to-iso8601 greasemonkey-user-script
Status: user-disabled

Name: Video DownloadHelper
Location: ${PROFILE_EXTENSIONS}/{b9db16a4-6edc-47ec-a1f4-b86292ed211d}.xpi
Status: enabled

Name: Web Compat
Location: ${PROFILE_EXTENSIONS}/webcom...@mozilla.org.xpi
Status: enabled

Name: Web Developer
Location: ${PROFILE_EXTENSIONS}/{c45c406e-ab73-11d8-be73-000a95be3b12}.xpi
Status: enabled

Name: Wikipedia font size userstyle
Status: enabled

Name: X-Ray
Location: ${PROFILE_EXTENSIONS}/{3f1182ea-3243-4d32-8826-71fb1cc9c328}.xpi
Status: enabled

Name: youtube-html5 greasemonkey-user-script
Status: enabled

-- Plugins information

-- Addons package information
ii  firefox-esr    52.3.0esr-2  amd64        Mozilla Firefox web browser - Ext

-- System Information:
Debian Release: buster/sid
  APT prefers unstable-debug
  APT policy: (500, 'unstable-debug'), (500, 'unstable'), (500, 'testing'), 
(500, 'stable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 4.11.0-2-amd64 (SMP w/8 CPU cores)
Locale: LANG=POSIX, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), LANGUAGE=POSIX 
(charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages firefox depends on:
ii  debianutils               4.8.2
ii  fontconfig                2.12.3-0.2
ii  libatk1.0-0               2.24.0-1
ii  libc6                     2.24-14
ii  libcairo-gobject2         1.14.10-1
ii  libcairo2                 1.14.10-1
ii  libdbus-1-3               1.11.16+really1.10.22-1
ii  libdbus-glib-1-2          0.108-2
ii  libevent-2.1-6            2.1.8-stable-4
ii  libffi6                   3.2.1-6
ii  libfontconfig1            2.12.3-0.2
ii  libfreetype6              2.6.3-3.2
ii  libgcc1                   1:7.1.0-13
ii  libgdk-pixbuf2.0-0        2.36.5-2
ii  libglib2.0-0              2.53.4-3
ii  libgtk-3-0                3.22.17-1
ii  libgtk2.0-0               2.24.31-2
ii  libhunspell-1.6-0         1.6.1-2
ii  libjsoncpp1               1.7.4-3
ii  libnspr4                  2:4.16-1
ii  libnss3                   2:3.32-1
ii  libpango-1.0-0            1.40.6-1
ii  libsqlite3-0              3.19.3-3
ii  libstartup-notification0  0.12-4+b2
ii  libstdc++6                7.1.0-13
ii  libvpx4                   1.6.1-3
ii  libx11-6                  2:1.6.4-3
ii  libx11-xcb1               2:1.6.4-3
ii  libxcb-shm0               1.12-1
ii  libxcb1                   1.12-1
ii  libxcomposite1            1:0.4.4-2
ii  libxdamage1               1:1.1.4-2+b3
ii  libxext6                  2:1.3.3-1+b2
ii  libxfixes3                1:5.0.3-1
ii  libxrender1               1:0.9.10-1
ii  libxt6                    1:1.1.5-1
ii  procps                    2:3.3.12-3
ii  zlib1g                    1:1.2.8.dfsg-5

firefox recommends no packages.

Versions of packages firefox suggests:
ii  fonts-lmodern          2.004.5-3
ii  fonts-stix [otf-stix]  1.1.1-4
ii  libcanberra0           0.30-3
ii  libgssapi-krb5-2       1.15.1-2
pn  mozplugger             <none>

-- no debconf information

Reply via email to