Package: license-reconcile
Version: 0.14
Severity: wishlist

Dear Maintainer,

I often came accross messges from license-reconcile with lines like

License mismatch: File
doc/Persistent_cohomology/Intro_persistent_cohomology.h has license
GPL-3+ which does not match GPL-3.0+.

when d/copyright e.g states GPL-3.0+
However, according to the dep-5 document:

> For SPDX compatibility, versions with trailing dot-zeroes are considered
> to be equivalent to versions without (e.g., “2.0.0” is considered equal
> to “2.0” and “2”). 

So it would be great (and reduces the amount of wrong messages
significantly) if license-reconcile would treat them as equivalent.

Thanks!

tobi

-- System Information:
Debian Release: buster/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 4.15.0-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US:en (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)
LSM: AppArmor: enabled

Versions of packages license-reconcile depends on:
ii  libclass-xsaccessor-perl       1.19-2+b11
ii  libconfig-any-perl             0.32-1
ii  libdebian-copyright-perl       0.2-4
ii  libdpkg-perl                   1.19.0.5
ii  libemail-address-perl          1.909-1
ii  libfile-fnmatch-perl           0.02-2+b5
ii  libfile-mmagic-perl            1.30-1
ii  libfile-slurp-perl             9999.19-6
ii  liblist-moreutils-perl         0.416-1+b3
ii  libparse-debianchangelog-perl  1.2.0-12
ii  libreadonly-perl               2.050-1
ii  libset-intspan-perl            1.19-1
ii  libsmart-comments-perl         1.06-1
ii  libtext-levenshteinxs-perl     0.03-4+b5
ii  libuniversal-require-perl      0.17-1
ii  licensecheck                   3.0.31-2
ii  perl                           5.26.1-5

Versions of packages license-reconcile recommends:
ii  libyaml-libyaml-perl  0.69+repack-1

license-reconcile suggests no packages.

-- no debconf information

Reply via email to