Package: zfsutils-linux
Version: 0.7.12-1
Severity: normal

Dear Maintainer,

Tried upgrading from stretch-backports 0.7.11 to testing 0.7.12, because
the package hadn't landed in backports yet, and discovered it broke on
dpkg --configure :
Setting up zfsutils-linux (0.7.12-1) ...
insserv: Service zfs-zed has to be enabled to start service zfs-share
insserv: exiting now!
update-rc.d: error: insserv rejected the script header
dpkg: error processing package zfsutils-linux (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of zfs-zed:
 zfs-zed depends on zfsutils-linux (>= 0.7.12-1); however:
  Package zfsutils-linux is not configured yet.

Someone else had reported a similar problem upstream to ZoL from Ubuntu's
packages, at:

I worked up a terrible hackjob of a patch to work around this long enough to
install it and then reverted the patch (attached), but there's probably a better
way to handle this.

(Don't mind the arc_summary changed warning; I've been testing improvements to 

-- System Information:
Debian Release: 9.6
  APT prefers stable-debug
  APT policy: (1000, 'stable-debug'), (1000, 'stable'), (900, 'testing-debug'), 
(900, 'testing'), (800, 'unstable-debug'), (800, 'unstable'), (500, 
'stable-updates'), (500, 'proposed-updates-debug'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.9.0-8-amd64 (SMP w/16 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages zfsutils-linux depends on:
ii  libblkid1        2.29.2-1+deb9u1
ii  libc6            2.24-11+deb9u3
ii  libnvpair1linux  0.7.12-1
ii  libuuid1         2.29.2-1+deb9u1
ii  libuutil1linux   0.7.12-1
ii  libzfs2linux     0.7.12-1
ii  libzpool2linux   0.7.12-1
ii  python3          3.5.3-1
ii  zlib1g           1:1.2.8.dfsg-5

Versions of packages zfsutils-linux recommends:
ii  lsb-base                9.20161125
ii  zfs-dkms [zfs-modules]  0.7.12-1
ii  zfs-zed                 0.7.12-1

Versions of packages zfsutils-linux suggests:
ii  nfs-kernel-server  1:1.3.4-2.1
ii  samba-common-bin   2:4.5.12+dfsg-2+deb9u4
ii  zfs-initramfs      0.7.12-1

-- Configuration Files:
/etc/sudoers.d/zfs [Errno 13] Permission denied: '/etc/sudoers.d/zfs'

-- debconf-show failed

-- debsums errors found:
debsums: changed file /usr/sbin/arc_summary (from zfsutils-linux package)
diff --git a/init.d/zfs-share b/init.d/zfs-share
index 6564720..2e800d1 100755
--- a/init.d/zfs-share
+++ b/init.d/zfs-share
@@ -9,8 +9,8 @@
 # Provides:          zfs-share
-# Required-Start:    $local_fs $network $remote_fs zfs-mount zfs-zed
-# Required-Stop:     $local_fs $network $remote_fs zfs-mount zfs-zed
+# Required-Start:    $local_fs $network $remote_fs zfs-mount
+# Required-Stop:     $local_fs $network $remote_fs zfs-mount
 # Default-Start:     2 3 4 5
 # Default-Stop:      0 1 6
 # Should-Start:      iscsi iscsitarget istgt scst nfs-kernel-server samba 
samba4 zfs-mount zfs-zed
@@ -34,7 +34,7 @@

-       after sysfs zfs-mount zfs-zed
+       after sysfs zfs-mount
        keyword -lxc -openvz -prefix -vserver

Reply via email to