Package: gnome
Version: 1:3.22+3
Severity: normal

Dear Maintainer,

When using the Gnome desktop, I cannot find the xterm icon by clicking
on Activities or by hitting the Super key and typing "xterm". I know
that I can run xterm by using Alt-F2, but that is not what I am
looking for.

Whenever I install Debian and use its default desktop, Gnome, it
always appears like xterm is missing. If I hit the Super key and type
in "term" I get these responses:

    * Multilingual Terminal
    * Thai X Terminal
    * Terminal              [Presumably Gnome-Terminal]

If I type in "xterm", Gnome just says "Searching..." until I get tired
and cancel it. I had assumed xterm wasn't installed by default and
I've been using Multilingual Terminal since, despite its flaws, it
does have SIXEL graphics support.

However, xterm is installed and it even has a proper desktop entry in
/usr/share/applications/debian-xterm.desktop. I expended way too much
time investigating why this didn't work, since it clearly should.

It turns out that some part of Gnome is creating a *second* desktop
file which disables the first one by setting 'NoDisplay = True'. 
The file is /usr/share/gnome/applications/debian-xterm.desktop
This is extremely frustrating and unnecessary. 

I wish I could tell you which part of Gnome is the culprit, but
`dpkg -S` on the file says it doesn't belong to any packages.

I can understand that certain distributions derived from Debian —
those which believe minimalism equates to simplicity — may wish to
hide "redundant" functionality like `xterm`. However, it doesn't make
sense to hide xterm from Debian users. And if it did, it certainly
should not be implemented in such a hard to discover way.

I request that Debian's Gnome stop overriding debian-xterm.desktop,
please. There are much better solutions.

Thank you.


P.S. Any distributions derived from Debian would of course be free to
create their own package which overrides debian-xterm.desktop. 
I suggest those distributions, instead of creating a second file,
create a package that runs

dpkg-divert --divert /usr/share/applications/debian-xterm.desktop.disabled \
            --rename /usr/share/applications/debian-xterm.desktop
            
That way, they will have stopped xterm from cluttering their menus,
but in a way that might be more easily discoverable by users trying to
re-enable it.



-- System Information:
Debian Release: 9.6
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 4.9.0-8-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8), 
LANGUAGE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages gnome depends on:
ii  avahi-daemon                     0.6.32-2
ii  cheese                           3.22.1-1+b1
ii  cups-pk-helper                   0.2.6-1+b1
ii  desktop-base                     9.0.2+deb9u1
ii  evolution                        3.22.6-1+deb9u1
ii  evolution-plugins                3.22.6-1+deb9u1
ii  file-roller                      3.22.3-1
ii  gedit-plugins                    3.22.0-1
ii  gimp                             2.8.18-1+deb9u1
ii  gnome-calendar                   3.22.4-2
ii  gnome-clocks                     3.22.1-1
ii  gnome-color-manager              3.22.2-1
ii  gnome-core                       1:3.22+3
ii  gnome-dictionary                 3.20.0-3+b1
ii  gnome-documents                  3.22.1-1
ii  gnome-getting-started-docs       3.22.0-1
ii  gnome-maps                       3.22.2-1
ii  gnome-music                      3.22.2-1
ii  gnome-orca                       3.22.2-3
ii  gnome-screenshot                 3.22.0-1+b1
ii  gnome-sound-recorder             3.21.92-2
ii  gnome-tweak-tool                 3.22.0-1
ii  gnome-weather                    3.20.2-1
ii  gstreamer1.0-libav               1.10.4-1
ii  gstreamer1.0-plugins-ugly        1.10.4-1
ii  inkscape                         0.92.1-1
ii  libgsf-bin                       1.14.41-1
ii  libgtk2-perl                     2:1.2499-1
ii  libproxy1-plugin-networkmanager  0.4.14-2
ii  libreoffice-calc                 1:5.2.7-1+deb9u4
ii  libreoffice-evolution            1:5.2.7-1+deb9u4
ii  libreoffice-gnome                1:5.2.7-1+deb9u4
ii  libreoffice-impress              1:5.2.7-1+deb9u4
ii  libreoffice-writer               1:5.2.7-1+deb9u4
ii  nautilus-sendto                  3.8.4-2+b1
ii  network-manager-gnome            1.4.4-1+deb9u1
ii  rhythmbox                        3.4.1-2+b1
ii  rhythmbox-plugin-cdrecorder      3.4.1-2+b1
ii  rhythmbox-plugins                3.4.1-2+b1
ii  rygel-playbin                    0.32.1-3
ii  rygel-tracker                    0.32.1-3
ii  seahorse                         3.20.0-3.1
ii  shotwell                         0.25.4+really0.24.5-0.1
ii  simple-scan                      3.23.2-1
ii  totem-plugins                    3.22.1-1
ii  vinagre                          3.22.0-1+b1
ii  xdg-user-dirs-gtk                0.10-1+b1

Versions of packages gnome recommends:
ii  brasero           3.12.1-4
ii  gnome-games       1:3.22+3
ii  polari            3.22.2-1
ii  transmission-gtk  2.92-2+deb9u1

Versions of packages gnome suggests:
pn  alacarte                                 <none>
pn  empathy                                  <none>
pn  firefox-esr-l10n-all | firefox-l10n-all  <none>
pn  goobox | sound-juicer                    <none>
pn  xul-ext-gnome-keyring                    <none>
pn  xul-ext-ublock-origin                    <none>

Versions of packages gnome-core depends on:
ii  adwaita-icon-theme            3.22.0-1+deb9u1
ii  at-spi2-core                  2.22.0-6+deb9u1
ii  baobab                        3.22.1-1
ii  caribou                       0.4.21-1+b1
ii  chrome-gnome-shell            8-4
ii  dconf-cli                     0.26.0-2+b1
ii  dconf-gsettings-backend       0.26.0-2+b1
ii  eog                           3.20.5-1+b1
ii  evince                        3.22.1-3+deb9u1
ii  evolution-data-server         3.22.7-1
ii  firefox-esr                   60.4.0esr-1~deb9u1
ii  fonts-cantarell               0.0.25-2
ii  gdm3                          3.22.3-3+deb9u2
ii  gedit                         3.22.0-2
ii  gkbd-capplet                  3.22.0.1-1+b1
ii  glib-networking               2.50.0-1+b1
ii  gnome-backgrounds             3.22.1-1
ii  gnome-bluetooth               3.20.1-1
ii  gnome-calculator              3.22.3-1
ii  gnome-characters              3.22.0-1
ii  gnome-contacts                3.22.1-1+b2
ii  gnome-control-center          1:3.22.2-3
ii  gnome-disk-utility            3.22.1-1
ii  gnome-font-viewer             3.22.0-1+b1
ii  gnome-keyring                 3.20.0-3
ii  gnome-logs                    3.22.1-2
ii  gnome-menus                   3.13.3-9
ii  gnome-online-accounts         3.22.5-1
ii  gnome-online-miners           3.22.0-1
ii  gnome-session                 3.22.3-1
ii  gnome-settings-daemon         3.22.2-2+deb9u2
ii  gnome-shell                   3.22.3-3
ii  gnome-shell-extensions        3.22.2-1
ii  gnome-software                3.22.5-1
ii  gnome-sushi                   3.21.91-2
ii  gnome-system-monitor          3.22.2-1
ii  gnome-terminal                3.22.2-1
ii  gnome-themes-standard         3.22.2-2
ii  gnome-user-guide              3.22.0-1
ii  gnome-user-share              3.18.3-1+b1
ii  gsettings-desktop-schemas     3.22.0-1
ii  gstreamer1.0-plugins-base     1.10.4-1
ii  gstreamer1.0-plugins-good     1.10.4-1
ii  gstreamer1.0-pulseaudio       1.10.4-1
ii  gvfs-backends                 1.30.4-1
ii  gvfs-bin                      1.30.4-1
ii  gvfs-fuse                     1.30.4-1
ii  libatk-adaptor                2.22.0-2
ii  libcanberra-pulse             0.30-3
ii  libcaribou-gtk-module         0.4.21-1+b1
ii  libcaribou-gtk3-module        0.4.21-1+b1
ii  libpam-gnome-keyring          3.20.0-3
ii  libproxy1-plugin-gsettings    0.4.14-2
ii  nautilus                      3.22.3-1+deb9u1
ii  pulseaudio                    10.0-1+deb9u1
ii  sound-theme-freedesktop       0.8-1
ii  system-config-printer-common  1.5.7-3
ii  system-config-printer-udev    1.5.7-3+b1
ii  totem                         3.22.1-1
ii  tracker-gui                   1.10.5-1
ii  vino                          3.22.0-1
ii  yelp                          3.22.0-1
ii  zenity                        3.22.0-1+b1

Versions of packages gnome-core recommends:
ii  anacron                          2.3-24
ii  libproxy1-plugin-networkmanager  0.4.14-2
ii  network-manager-gnome            1.4.4-1+deb9u1

gnome-core suggests no packages.

-- no debconf information

--1549612708-eximdsn-1804289383--

Reply via email to