Dmitry Bogatov wrote on 19/05/2019:
> [2019-05-17 18:43] Paride Legovini <>
>> I tried with xterm and sakura, the Cyrillic string renders exactly as
>> in stterm, with the correct character width and spacing.
> I have found workaround. My regular locale is eo.utf-8, but many X
> applications (stterm included) fail to start with following error:
>       XOpenIM failed. Could not open input devices.
> so I start them with LC_ALL=C.UTF-8. Funny thing, I just tried to start
> "LC_ALL=ru_RU.utf8 stterm -f Terminus", and it rendered cyrillic text
> properly.
> But I still believe, that different rendring on different utf-8 locales
> is a bug. Can you re-do checks with LC_ALL=C.UTF-8?

This is indeed strange. I don't doubt your report, but I still can't
reproduce the problem. This is what I did:

1. Start the terminal: LC_ALL=C.UTF-8 stterm -f Terminus
2. Run locale(1) from within the terminal to confirm that the locale
   settings get applied correctly; they do
3. Run: echo Привет
4. The Cyrillic letters get printed and echoed normally, no extra space.

>> On my system I have disabled the bitmap fonts: I have this
>> symbolic link in place:
>> /etc/fonts/conf.d/70-no-bitmaps.conf ->
>> /usr/share/fontconfig/conf.avail/70-no-bitmaps.conf
> No, I did no configuration in /etc/fonts/conf.d. I wasn't aware of it.

The link is created (or deleted) when configuring fontconfig-config. If
you are not getting asked about bitmap fonts try with dpkg-reconfigure
-p low. I tried to re-enable the bitmap fonts in this way but nothing

If you compile st directly from the upstream source does the problem
show up? What about the older versions? Compiling st is quick and easy,
so this might be worth trying.

Let me know if there is anything else I can try.


Reply via email to