On 02/13/17 20:25, Santiago Vila wrote:
> This is just how the build ends, not necessarily the relevant part.
> I've put several build logs here:
> https://people.debian.org/~sanvila/build-logs/aiocoap/
> If this is really a bug in one of the build-depends, please use reassign and 
> affects,
> so that this is still visible in the page for this package.
> The bug should be reproducible with sbuild on a single CPU virtual machine,
> provided you try enough times (as the failure happens randomly).

Hi Santiago, sorry for the looonggg delay. I have tried to reproduce it with no
success. Could you tell me more about your setup please?
I'm using the following command for testing it

set -e && for i in $(seq 10); do docker run --rm -it debian:stretch bash -c
'echo "deb-src http://deb.debian.org/debian stretch main" >
/etc/apt/sources.list.d/sources.list && apt-get update && apt-get install
eatmydata -y && eatmydata apt-get install dpkg-dev -y && apt-get source
aiocoap; eatmydata apt-get build-dep aiocoap -y && cd aiocoap-0.1+9ae36f4/ &&
dpkg-buildpackage -j$(getconf _NPROCESSORS_ONLN) -A'; done

Also I've tried using schroot and it finished correctly as well. As you can
see, I ran the command successfully 10 times, with multiple cores, with only
one core, etc. Please let me know if there is anything special on your setup to
be able to reproduce it.



Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to