Your message dated Thu, 07 Feb 2019 03:13:19 +0000
with message-id <>
and subject line Bug#920171: Removed package(s) from unstable
has caused the Debian Bug report #843198,
regarding gcc-6: Cross-compiles older GCC badly
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: gcc-6
Version: 6.2.0-11
Severity: normal

I'm working on a project that uses a Linaro gcc 4.8.3 cross compiler for
ARM, which I'm building on my Debian desktop.

As of gcc-6 6.2.0-6, this worked fine.

As of gcc-6 6.2.0-10, a subtly bad cross-compiler seems to be generated.  My
build is failing in an area related to precompiled headers:

cc1: warning: /path/to/foo.h.gch: had text segment at different address 
[enabled by default]
cc1: error: one or more PCH files were found, but they were invalid
cc1: fatal error: /path/to/foo.h: No such file or directory

I confirmed that if I downgrade all the binary packages I have installed
from the gcc-6 source to 6.2.0-6 and rebuild, things work again.

Scanning the changelogs, I came upon the idea that the default enabling of
-fPIE/-pie in 6.2.0-7 might have something to do with this, so I switched to
that version and tried again, and it failed, so at the very least the
problem is something that came in between the -6 and -7 releases.

Rebuilding the cross-toolchain with -fno-PIE -no-pie produced linker errors
complaining that it needed -fPIC, and rebuilding with -fno-PIE -no-pie -fPIC
produced the same errors, so I don't know what to do now :(

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.7.0-1-amd64 (SMP w/8 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages gcc-6 depends on:
ii  binutils
ii  cpp-6         6.2.0-6
ii  gcc-6-base    6.2.0-6
ii  libc6         2.24-5
ii  libcc1-0      6.2.0-6
ii  libgcc-6-dev  6.2.0-6
ii  libgcc1       1:6.2.0-6
ii  libgmp10      2:6.1.1+dfsg-1
ii  libisl15      0.17.1-1
ii  libmpc3       1.0.3-1
ii  libmpfr4      3.1.5-1
ii  libstdc++6    6.2.0-6
ii  zlib1g        1:1.2.8.dfsg-2+b3

Versions of packages gcc-6 recommends:
ii  libc6-dev  2.24-5

Versions of packages gcc-6 suggests:
ii  gcc-6-doc         6.1.0-1
pn  gcc-6-locales     <none>
pn  gcc-6-multilib    <none>
pn  libasan3-dbg      <none>
pn  libatomic1-dbg    <none>
pn  libcilkrts5-dbg   <none>
pn  libgcc1-dbg       <none>
pn  libgomp1-dbg      <none>
pn  libitm1-dbg       <none>
pn  liblsan0-dbg      <none>
pn  libmpx2-dbg       <none>
pn  libquadmath0-dbg  <none>
pn  libtsan0-dbg      <none>
pn  libubsan0-dbg     <none>

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 6.5.0-2+rm

Dear submitter,

as the package gcc-6 has just been removed from the Debian archive
unstable we hereby close the associated bug reports.  We are sorry
that we couldn't deal with your issue properly.

For details on the removal, please see

The version of this package that was in Debian prior to this removal
can still be found using

This message was generated automatically; if you believe that there is
a problem with it please contact the archive administrators by mailing

Debian distribution maintenance software
Scott Kitterman (the ftpmaster behind the curtain)

--- End Message ---

Reply via email to