some time ago i wrote C++ code to save backtrace in a vector of strings. it worked fine until one of system updates (~month ago), when it suddenly started to show too short listening(s). i've tried example from manual (man backtrace) to verify this, and it does not work properly too. example output is:

$ gcc -Wall -g3 -rdynamic main.c && ./a.out 10
backtrace() returned 4 addresses
./a.out(_Z7myfunc3v+0x1c) [0x400b28]
./a.out [0x400ba9]
./a.out(_Z6myfunci+0x23) [0x400bce]
./a.out(_Z6myfunci+0x1c) [0x400bc7]

where there should be >10 calls on stack. raising number given as an argument does not change output.

do you know what can be the reason for problems with backtrace? it looks like glibc problem, since before system upgrade (~month ago, but i may not be very accurate here) everything worked as a charm.

i'm using debian/testing, with gcc 4:4.3.4-1 and glibc-2.10-1.

pozdrawiam serdecznie / best regards,
Bartek 'BaSz' Szurgot

Wroclaw Centre for Networking and Supercomputing
Wroclaw University of Technology,
pl. Grunwaldzki 9, D2/101,
50-377 Wroclaw

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Reply via email to