On Oct 06, Aurelien Jarno <aurel...@aurel32.net> wrote:

> Ah this doesn't match the version in unstable, it's only in NEW for now.
> I guess we need to wait for it to get out of there first.
For reasons which I do not understand, the ftpmasters obliquely let me 
know that they will not accept libxcrypt from NEW until the libc 
maintainers will explicitly confirm that we have agreed on a plan to use 
it. Do you mind confirming this?

> > So I think that libc6 should have Depends/Replaces on libcrypt1.
> Agreed for the Depends. I don't get why it needs a Replaces. On the
> other hand libcrypt1 needs a Replaces: libc6, libc6.1, libc0.1, libc0.3
> with the correct version.
Yes, this is what I meant. So:

Package: libcrypt1
Breaks: libc6 (<< 2.29-X)
Replaces: libc6 (<< 2.29-X)

Package: libcrypt1-dev
Breaks: libc6-dev (<< 2.29-X)
Replaces: libc6-dev (<< 2.29-X)

Package: libc6
Depends: libcrypt1

Package: libc6-dev
Depends: libcrypt1-dev

And all the architecture-specific variations which I will figure out.

(Also, do not forget about the man pages in the -dev packages.)

There is also a libcrypt1 udeb: do you prefer to start building it now 
or deal with it later?


Attachment: signature.asc
Description: PGP signature

Reply via email to