Package: lintian Version: 2.141.0 Severity: wishlist X-Debbugs-Cc: [email protected], [email protected], [email protected], [email protected]
Dear Lintian Maintainers, With the ongoing Go Team transition to `dh-go` and module-aware builds, the team has updated the naming conventions for Go packages. You can find the diff of changes here: https://wiki.debian.org/action/info/Teams/DebianGoTeam/ModuleAwareBuilds?action=diff&rev2=11&rev1=8&utm_source=gemini Under the updated guide, source package rename are minimized to reduce maintenance overhead. So that, the tag check source package name to matches API version such as `go-source-package-does-not-include-version` may retired. And the package naming check should focus on the `-dev` binary packages for tag `go-library-package-does-not-include-version`. Maybe needs some enhance to inspect the root `go.mod` file shipped within the `-dev` binary package and verify that: 1. The major API version suffix in the go import path of the root `go.mod` matches the `-vN` suffix in the binary package name. 2. If import path containing slashes and dots for versioned suffix (eg: `/pkg.v3`) convert slashes to hyphens and preserve the dot (eg: `-pkg.v3-dev`) to avoid naming confusions. Checking the root `go.mod` file within the binary package provides two main benefits: 1. Validates the binary package name matches its Go import path. 2. Avoids false-positive warnings on transitional packages that do not ship a `go.mod` file. Thank you for your great work on Lintian! Best regards, -Andrew
