On 02/19/2018 10:26 AM, Frank Scheiner wrote:
There's a new package version (2.02+dfsg1-1) available since a few days ([1]).


Installing it **and** using the mentioned `grub-install` command to install it 
on the `/boot` partition over the previous version (2.02-2+sparc64.3) breaks 
booting with GRUB2:

Yes, this is something I don't have any control over. The grub2 package will
break every time on sparc64 until GRUB 2.04 has been released with hopefully
all of Eric's patches merged.

Alternatively, you can try to convince Debian's GRUB maintainers (CC'ed) that
they will merge my patch from #854568 [1].

Additionally, you will have to add the following in debian/rules for 

ifneq (,$(filter sparc sparc64,$(DEB_HOST_ARCH_CPU)))
export TARGET_LDFLAGS := -no-pie

Could or will you provide a new package with Eric's patches included - assuming 
those are missing in 2.02+dfsg1-1?
Well, this will break over and over again, so I rather prefer getting the
patch merged into the Debian package officially.


[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=854568

 .''`.  John Paul Adrian Glaubitz
: :' :  Debian Developer - glaub...@debian.org
`. `'   Freie Universitaet Berlin - glaub...@physik.fu-berlin.de
  `-    GPG: 62FF 8A75 84E0 2956 9546  0006 7426 3B37 F5B5 F913

Reply via email to