We've recently started seeing (on Jessie) these failures from "apt-get
install crossbuild-essential-armhf":

    The following packages have unmet dependencies:
     crossbuild-essential-armhf :
         Depends: gcc-arm-linux-gnueabihf (>= 4.9.1-1) but it is not going
to be installed
         Depends: g++-arm-linux-gnueabihf (>= 4.9.1-1) but it is not going
to be installed
    E: Unable to correct problems, you have held broken packages.

It looks like this may be a recurrence of an earlier problem ([1]):
recently gcc-4.9 upgraded ([2]) from 4.9.2-10 to 4.9.2-10+deb8u1,
but gcc-4.9-arm-linux-gnueabihf and g++-4.9-arm-linux-gnueabihf (both still
at 4.9.2-10) have a strict dependency on the 4.9.2-10 packages ([3]).

[1] https://lists.debian.org/debian-embedded/2015/03/msg00001.html
[3] http://emdebian.org/tools/debian/dists/jessie/main/binary-amd64/Packages

Would you be able to push new versions (probably 4.9.2-10+deb8u1) of
both gcc-4.9-arm-linux-gnueabihf
and g++-4.9-arm-linux-gnueabihf at some point, with upgraded dependencies?
We might also consider switching out some of these strict = dependencies
for >=, to allow for possible future gcc-4.9 upgrades.

Thanks very much for the help!


Reply via email to