He provat a posar en marxa l'esmentada impressora i em dóna problemes.
He instal·lat els paquets: hplip hpijs-ppds printer-driver-pxljr
Al web de HPLIP diu que aquesta impressora està suportada des de la
versió 2.7 i el HPLIP instal·lat ja és la 3.16

D'entrada hi ha un controlador «HP LaserJet 1018 Foomatic/foo2zjs-z1
(recommended)» amb el qual no funciona (l'ordinador pensa que imprimeix,
però la impressora ni s'immuta).
Els demés controladors llistats per CUPS tenen l'anotació «requires
proprietary plugin». Suposo doncs que no hi ha més remei que instal·lar
el paquet privatiu proporcionat des de hplipopensource.com

Descarrego i executo:
$ ./hplip-3.17.11.run
(...)
error: debian-9.3 version is not supported, so all dependencies may not
be installed. However trying to install using debian-9.1 version packages.
-> Li dic que continui així, i endavant amb les propostes predeterminades.
(...)
error: A required dependency 'pyqt4-dbus (PyQt 4 DBus - DBus Support for
PyQt4)' is still missing.
error: A required dependency 'pyqt4 (PyQt 4- Qt interface for Python
(for Qt version 4.x))' is still missing.
error: Installation cannot continue without these dependencies.
error: Please manually install this dependency and re-run this installer.

Arreu he llegit que el problema està en què a Debian aquests paquets
s'anomenen python-qt4-dbus i python-qt4 respectivament. He provat a
modificar els fitxers de l'instal·lador per rectificar-ho, però encara
que sigui amb els nous noms no es dóna per satisfet.

-- 


__________
I'm using this express-made address because personal addresses aren't
masked enough at this mail public archive. Public archive administrator
should fix this against automated addresses collectors.

Respondre per correu electrònic a