Després d'aquest temps, considero resolt el primer problema, ja que
aquesta interfície de xarxa no dóna el més mínim problema des de
l'actualització del controlador.

Només falta la manera de què el controlador actualitzat s'apliqui a les
noves versions de nucli que vinguin per actualitzacions.


El 15/02/18 a les 10:50, Narcis Garcia ha escrit:
> De moment, m'he apuntat aquesta recepta solventant fins i tot un
> problema del «Makefile» del mateix projecte:
> 
> 0. Install build/compiler tools:
> sudo apt-get install build-essential linux-headers-amd64
> 
> 1. Download latest stable version from:
> https://sourceforge.net/projects/e1000/files/e1000e%20stable/
> 
> 2. Unpack:
> tar zxf e1000e-*.tar.gz
> 
> 3. Compile and install:
> cd e1000e-*/src/
> sudo make install
> 
> 3.1. If it fails with "cc1: error: code model kernel does not support
> PIC mode"
> # Find in Makefile ( e1000e/src/Makefile , Line ~152) =>
> EXTRA_CFLAGS += $(CFLAGS_EXTRA)
> # Insert a new line after that => EXTRA_CFLAGS += -fno-pie
> sudo make install
> 
> 4. Where is the binary installed:
> find /lib/modules | grep -e '/e1000e\.ko$'
> /lib/modules/4.9.0-5-amd64/updates/drivers/net/ethernet/intel/e1000e/e1000e.ko
> /lib/modules/updates/drivers/net/ethernet/intel/e1000e/e1000e.ko
> 
> 5. Updated boot-embedded driver:
> sudo update-initramfs -u
> 
> 
> Els diferents e1000e.ko generats no són iguals.
> Com que veig que no es crea automàticament per cada nucli (com el
> 4.9.0-4 que també hi ha instal·lat),
> EL QUÈ EM QUEDA ARA, és trobar la manera que tot això es posi com cal el
> dia que actualitzi el sistema (a Linux 4.9.0-6 per exemple) sense haver
> de recordar i recuperar tot el procediment manual.
> 
> 
> 
> 
> __________
> I'm using this express-made address because personal addresses aren't
> masked enough at this mail public archive. Public archive administrator
> should fix this against automated addresses collectors.
> El 07/02/18 a les 14:29, Narcis Garcia ha escrit:
>> He descarregat el paquet linux-image-4.14.0-0.bpo.3-amd64 del repositori
>> «backports» i veig que el mòdul-controlador que conté és de la mateixa
>> versió:
>> filename:
>> ./lib/modules/4.14.0-0.bpo.3-amd64/kernel/drivers/net/ethernet/intel/e1000e/e1000e.ko
>> version: 3.2.6-k
>>
>> El mateix amb el paquet linux-image-4.14.0-3-amd64 del repositori
>> sid/unstable:
>>
>> filename:
>> ./lib/modules/4.14.0-3-amd64/kernel/drivers/net/ethernet/intel/e1000e/e1000e.ko
>> version: 3.2.6-k
>>
>> La meva idea era reemplaçar solsament aquest fitxer, si fos possible
>> obtenir-lo ja compilat i compatible amb Debian 9. Igualment espero a què
>> algú pugui comprovar que no és el cable el què falla, ja que els altres
>> 2 ordinadors bessons no tenen aquest problema.
>>
>>
>> __________
>> I'm using this express-made address because personal addresses aren't
>> masked enough at this mail public archive. Public archive administrator
>> should fix this against automated addresses collectors.
>> El 04/02/18 a les 19:52, Narcis Garcia ha escrit:
>>> El controlador ve amb el paquet linux-image-4.9.0-5-amd64 i l'únic
>>> fitxer relacionat sembla ser:
>>> /lib/modules/4.9.0-5-amd64/kernel/drivers/net/ethernet/intel/e1000e/e1000e.ko
>>> No en sé veure la versió.
>>>
>>> Ara estic veient que els 3 ordinadors en qüestió no tenen exactament el
>>> mateix problema. Només és un que no es recupera definitivament després
>>> de perdre l'estat «link ok».
>>>
>>> __________
>>> I'm using this express-made address because personal addresses aren't
>>> masked enough at this mail public archive. Public archive administrator
>>> should fix this against automated addresses collectors.
>>>
>>> El 04/02/18 a les 13:36, Josep Lladonosa ha escrit:
>>>> Narcís, mira't això!
>>>>
>>>> https://sourceforge.net/projects/e1000/files/e1000e%20stable/3.3.6/
>>>>
>>>> Sembla que t'has trobat amb un bug que s'ha resolt en la versió 3.3.6
>>>> del controlador e1000e. Val a dir que ara van per la 3.4.0.2.
>>>>
>>>> https://sourceforge.net/projects/e1000/files/e1000e%20stable/3.4.0.2/
>>>>
>>>> Quina versió tens tu?
>>>>
>>>>
>>>> 2018-02-04 13:01 GMT+01:00 Josep Lladonosa <jllad...@gmail.com
>>>> <mailto:jllad...@gmail.com>>:
>>>>
>>>>     Hola, Narcís,
>>>>
>>>>     Apunt:
>>>>     Si el controlador es troba com a mòdul, potser es pot eliminar el
>>>>     mòdul (rmmod) i tornar-lo a incorporar (modprobe) per tal d'evitar
>>>>     de fer reboot. Si torna a funcionar aleshores podries determinar que
>>>>     sí que és el controlador.
>>>>
>>>>     Veig que funcionen a 1 Gbps. Els cables estan ben fets? Pateixen
>>>>     d'alguna interferència? Ho dic perquè podria ser que hi hagués
>>>>     alguna renegociació a nivell físic i que el controlador no la
>>>>     contempli, quedant "estabornit"...
>>>>
>>>>     Potser podria afectar a la cosa el fet que les targetes tinguin els
>>>>     noms llargs (en lloc dels ethX tradicionals). Podria estar
>>>>     relacionat amb DHCP i la renovació?
>>>>
>>>>     Salutacions,
>>>>     Josep
>>>>
>>>>     2018-02-03 15:36 GMT+01:00 Narcis Garcia <debianli...@actiu.net
>>>>     <mailto:debianli...@actiu.net>>:
>>>>
>>>>         00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet
>>>>         Connection (2) I219-LM [8086:15b7] (rev 31)
>>>>
>>>>         Ja m'he trobat amb 3 ordinadors que utilitzen aquest xip de
>>>>         xarxa integrat a la placa base (la mateixa als tres), amb Debian
>>>>         9 (sense escriptori):
>>>>
>>>>         Havent engegat l'ordinador, després d'un interval d'entre 5 i 20
>>>>         hores, la xarxa deixa de funcionar. Sense perdre la configuració
>>>>         que tenia per DHCP, ja no hi ha comunicació ni tan sols amb el
>>>>         router (ni ping ni res), és a dir com si l'ordinador estigués
>>>>         sol a la xarxa.
>>>>
>>>>         Com que aquests ordinadors no els tinc a casa, els he creat un
>>>>         servei que intenta accions i enregistra els esdevniments. Aquí
>>>>         la bitàcola d'un procés complet fins a reiniciar l'ordinador,
>>>>         que és la única solució:
>>>>
>>>>         === Failure history ===
>>>>         2018-02-03 11:05:48 CPUs:0% enp0s31f6::1000baseT-FD::link-ok
>>>>         IP:192.168.1.33 Gateway:192.168.1.1:Alive Internet:Yes
>>>>         2018-02-03 11:07:49 CPUs:0% enp0s31f6::1000baseT-FD::link-ok
>>>>         IP:192.168.1.33 Gateway:192.168.1.1:Alive Internet:Yes
>>>>         2018-02-03 11:09:50 CPUs:2% enp0s31f6::1000baseT-FD::link-ok
>>>>         IP:192.168.1.33 Gateway:192.168.1.1:Alive Internet:Yes
>>>>         2018-02-03 11:14:02 CPUs:0% enp0s31f6:no-link IP:192.168.1.33
>>>>         Gateway:192.168.1.1:Fails Internet:No
>>>>         2018-02-03 11:18:14 CPUs:1% enp0s31f6::1000baseT-FD::link-ok
>>>>         IP:192.168.1.33 Gateway:192.168.1.1:Fails Internet:No
>>>>         2018-02-03 11:18:14 Trying to notify to: narcis@...
>>>>         2018-02-03 11:18:15 $ ifdown "enp0s31f6"
>>>>         2018-02-03 11:18:15 $ sleep 2
>>>>         2018-02-03 11:18:17 $ ifup "enp0s31f6"
>>>>         2018-02-03 11:21:46 CPUs:1% enp0s31f6::1000baseT-FD::link-ok IP:
>>>>         Gateway::No Internet:Unroutable
>>>>         2018-02-03 11:23:49 CPUs:2% enp0s31f6::1000baseT-FD::link-ok IP:
>>>>         Gateway::No Internet:Unroutable
>>>>         2018-02-03 11:23:49 $ dhclient "enp0s31f6"
>>>>         2018-02-03 11:26:53 CPUs:6% enp0s31f6::1000baseT-FD::link-ok IP:
>>>>         Gateway::No Internet:Unroutable
>>>>         2018-02-03 11:26:53 $ dhclient "enp0s31f6"
>>>>         2018-02-03 11:29:57 CPUs:1% enp0s31f6:no-link IP: Gateway::No
>>>>         Internet:Unroutable
>>>>         2018-02-03 11:29:57 Trying to notify to: narcis@...
>>>>         2018-02-03 11:29:58 $ reboot
>>>>
>>>>         * La informació de l'enllaç la obtinc amb: mii-tool enp0s31f6
>>>>         * La informació de la IP popia amb: ip address show enp0s31f6
>>>>         * La informació del router (gw) amb: netstat -rn
>>>>         * La disponibilitat del router es detecta amb: ping -c 1 
>>>> 192.168.1.1
>>>>         * La disponibilitat d'internet es detecta amb: nc -v -w 4 -z
>>>>         216.146.35.35 53
>>>>
>>>>         El router va perfectament i fa l'assignació DHCP quan realment
>>>>         rep la petició. Perquè li deixa de funcionar la xarxa a
>>>>         l'ordinador? Com puc analitzar millor el problema? Pot ser cosa
>>>>         del controlador *e1000e* que utiltza Debian?
>>>>
>>>>         Gràcies.
>>>>
>>>>         -- 
>>>>
>>>>
>>>>         __________
>>>>         I'm using this express-made address because personal addresses 
>>>> aren't masked enough at this mail public archive. Public archive 
>>>> administrator should fix this against automated addresses collectors.
>>>>
>>>>
>>>>
>>>>
>>>>     -- 
>>>>     --
>>>>     Salutacions...Josep
>>>>     --
>>>>
>>>>
>>>>
>>>>
>>>> -- 
>>>> --
>>>> Salutacions...Josep
>>>> --
>>
> 

Respondre per correu electrònic a