Le 03/03/2018 à 10:17, didier gaumet a écrit :
> comme ton portable a l'air d'être un Pentium M 32 bits avec
> potentiellement peu de mémoire, 
:~$ free -h
                     total        used         free       shared 
buff/cache   available
Mem:           994M        288M        311M         71M       
395M        497M
Swap:          1,0G             0B          1,0G

Je ne sais pas à partir de combien tu considères qu'il y a peu de mémoire.
Je peux dire que :
=> l'installeur stretch, une fois le problème contourné, a fonctionné
sans problème
=> j'avais envisagé un blocage dû à une limitation de taille mémoire, et
j'ai tenté au moins une install avec l'option « lowmem », et le blocage
était le même.


> il se pourrait que tes problèmes soient
> causés par PAE: si je me souviens bien à une époque le noyau linux par
> défaut pour x86 dans Debian était non-PAE et est devenu PAE dans la
> version suivante. Or les Pentium M (ou au moins certains d'entre eux)
> rapportent généralement qu'ils sont incompatibles PAE alors qu'en
> réalité ils sont compatibles. Donc je suggérerais:
> - de démarrer l'installateur avec le paramètre noyau forcepae
> - si tu n'as pas beaucoup de mémoire, de démarrer l'installateur avec
> l'option lowmem
> - de démarrer l'installateur en version texte plutôt que graphique (ça
> doit consommer moins de mémoire)
c'est ce que je fais toujours. J'ai quand même aussi, cette fois-ci,
tenté aussi des installs via graphique.
> - de démarrer l'installateur en mode expert plutôt que normal, il y a
> toujours plus d'infos
c'est aussi toujours avec cette option que j'installe. Il me semble
qu'on n'a pas vraiment plus d'infos au sens strict, mais plutôt des
choix plus détaillés.
Mais les options « graphique » et « expert install » ne permettent pas
de s'arrêter juste avant le blocage, ie avant la phase « configuration
des sources d'apt », ce qui aurait été bien intéressant. Mon idée aurait
été alors de sauter la configuration d'apt, installer grub, puis faire
booter la machine sur cette install.
Il y a peut-être une piste dans cette direction-là ?
> - si ça ne suffit pas à résoudre ton problème: recommencer
> l'installation puis tant que le CDROM est reconnu, basculer sur une
> console (il me semble que par défaut la 2ème par CTRL-ALT-F2 est dispo
> pour ça), taper mount pour voir où est monté le CDROM, poursuivre
> l'installation jusqu'au problème puis rebasculer dans une console et
> tenter de monter le CDROM là où il était monté précédemment) et en cas
> de succès terminer l'install
>

Répondre à