On Friday 14 October 2016 20:51:43 you wrote:

> Gene
> Have you tried running the program manually?  And report output here
> Keith Bainbridge
> 0447667468
> keithrbaugro...@gmail.com
> Sent from my APad
> On 15 Oct 2016 04:35, "Gene Heskett" <ghesk...@shentel.net> wrote:
> > Greetings all;
> >
> > I run my own webserver, at the address below in the sig.
> >
> > And I have awffull in my crontab as
> > 40 9 * * *  awffull
> >
> > And it sends me an email saying "Graph done!"
> >
> > But the last time all the data in /var/www/awffull was updated was
> > on Sept 30th, 2016.  So while its not reporting any error when I run
> > an extra session from the cli, I am locked out of seeing the data
> > until the 1st of the next month.
> >
> > Nothing in the config looks like it could cause this.
> >
> > Anybody have a clue? I seem to be fresh out of clues.
> >
> > Thanks all.

Well, I am a wee bit schmardter.

I found a bash script in /etc/cron.daily named awffull.
Running that script instead of the binary in /usr/bin appeared to work so 
I edited my crontab to run this script instead.

Come time for cron to run it as me, I got an email about 4 pages long, 
the gist of which was that I didn't have enough perms to make it run, so 
I moved that entry to root's crontab.  Works if I sudo bash to run it.  
One final error:

root@coyote:/etc/awffull#  /etc/cron.daily/awffull
Running: /etc/awffull/awffull.conf file.
ERROR: Running awffull, exit status: 1

If a rerun is done when there are no new entries in the log files, so I 
tested it by accessing my web page from localhost, which would append to 
the log files.

Error gone and everythings time stamps were updated.

Did you ever hear of majestic12.co.uk? They sucked my whole web content, 
nearly 3.5G yesterday. Wannabe google? or???

Thanks Keith.

Cheers, Gene Heskett
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>

Reply via email to