I'm running Debian Trixie on an AMD64 system. I'm running 2 RAID-6 arrays on a set of 4 disks, with each disk having 2 partitions on it/

After a reboot this morning, the The RAID-6 array for /home failed to start. cat /proc/mdstat showed 3 of the 4 disks as (S) but didn't show the 4th at all. smartctl showed the health of the missing disk as PASSED, which was expected because the other RAID-6 array started with all 4 partitions.

mdadm --assemble --run /dev/md0  /dev/sdc1 /dev/sdd1 /dev/sdb1  started the array with one member missing. I had previous tried it with all 4 partitions listed and that failed so the fall-back of running with only 3 members is OK for now.

# cat /proc/mdstat
Personalities : [raid6] [raid5] [raid4] [raid0] [raid1] [raid10]
md0 : active raid6 sdc1[6] sdd1[5] sdb1[4]
      3907011584 blocks super 1.2 level 6, 8k chunk, algorithm 2 [4/3] [U_UU]

md1 : active raid6 sde2[7] sdc2[6] sdd2[5] sdb2[4]
      3907021448 blocks super 1.2 level 6, 4k chunk, algorithm 2 [4/4] [UUUU]

However I can't re-add the 4th partition (/dev/sde1) into the array. For example (just some of the thing's I've tried):

# mdadm --manage  /dev/md0 --add /dev/sde1 --force
mdadm: add new device failed for /dev/sde1 as 7: Invalid argument
mdadm: Cannot read superblock on /dev/sde1
# mdadm  --zero-superblock /dev/sde1
mdadm: Unrecognised md component device - /dev/sde1
# mdadm --manage  /dev/md0 --re-add /dev/sde1
mdadm: --re-add for /dev/sde1 to /dev/md0 is not possible

Any ideas on how I can get the partition back into the array?

Thanks.

Reply via email to