On February 4, 2018 at 12:39 PM Richard Shann wrote:

On Sun, 2018-02-04 at 11:52 -0500, Bric wrote:
Copied over a sync'ed pair from Windows, and ran the Ubuntu
denemo -
segfaults at the same stage
This becomes interesting - can you email your Default.commands,
Default.shortcuts files and I can look at what may be going on
The attached files are the windows defaults i tried to impose on my
new Ubuntu build, that led to the crash.

Your Default.commands is faulty. As you haven't created any custom
commands you can copy the Default.commands from the installation (or
git ...) into your .denemo-2.2.?/actions directory to replace the one
you took from your Windows installation. That works fine with your
Default.shortcuts (giving for example, Ctrl-Shift-2 for insert duplet).

I've pushed an refinement to the code so that it will not crash with
that sort of erroneous Default.commands (I suspect the fault may arise
because windows paths don't start with a \, but I'm not sure)

Yay! that worked !

I should note, though, that "make install" did not place "Default.commands" in my ~/.denemo-2.2.1/actions$ directory (nor Default.shortcuts)

And, apparently, "Default.commands" is needed to load "Default.shortcuts" (?)

So... I initially copied over just "Default.shortcuts", and observed the old shortcuts do not get loaded (just confirmed this again two minutes ago).  Then I copied over the "Default.commands" - and observed the segfault.

All is well that ends well. Thanks.

Denemo-devel mailing list

Reply via email to