hi Ole, i have the same problem (derby version 10.2.2) and my opinion is, that the server has stopped, but should not have done that. it should have rejected the connection without a stop. But there is still the question "how to stop the server correctly".
Kay -----Ursprüngliche Nachricht----- Von: Ole Gunnar Borstad [mailto:[EMAIL PROTECTED] Gesendet: Mittwoch, 25. Juli 2007 14:45 An: [email protected] Betreff: Shutdown Network Server w/ auth enabled Derby Developer's Guide states the following: "When Derby is running in a connectivity server and user authentication is turned on, stopping the server requires a user name and password. You will need to alter shutdown scripts accordingly." I don't seem to find a command or argument to shutdown the network server when authentication is enabled in Derby...? I did a simple java -jar derbynet.jar shutdown and the server prints the following: Derby shutdown warning: Connection refused : Invalid authentication. Apache Derby Network Server - 10.4.0.0 alpha - (554547M) shutdown at 2007-07-25 12:31:08.948 GMT So did the server shut down properly or not? -------------------------- ckc ag Sitz: Industriestr. 10 38110 Braunschweig Telefon 05307 / 80 20 0 Telefax 05307 / 80 20 444 http://www.ckc.de Amtsgericht Braunschweig HRB 5405 Vorstand: H.-G. Christian Krentel (Vorsitzender) Aufsichtsrat: Dr. Heinz-Werner Weinrich (Vorsitzender) Hans Bodenstein Dr. Rita Schulz --------------------------
